Devstack Multinode ocata installation

asked 2017-03-09 11:48:01 -0500

cmaiorano gravatar image

I've a 3 node environment (1 controller/network/cpu and 2 compute) with two interfaces on controller and one for each compute node. The first interface on controller is connected to public network and is accesible from outside, the second is connected to a tagged vlan where also the compute nodes are connected. The connection between vlan interface and public interface are "forwarded" with iptables, so compute nodes has access to internet

This is the network snippet of my controller configuration:

 HOST_IP= "My Public ip"
 SERVICE_HOST=$HOST_IP
 MYSQL_HOST=$SERVICE_HOST
 RABBIT_HOST=$SERVICE_HOST
 GLANCE_HOSTPORT=$SERVICE_HOST:9292
 FIXED_RANGE=10.0.0.0/24
 NETWORK_GATEWAY=10.0.0.1
 FLAT_INTERFACE=vlan-interface
 PUBLIC_INTERFACE=vlan-interface
 PUBLIC_NETWORK_GATEWAY=vlan-interface-ip
 FLOATING_RANGE=vlan ip range
 Q_FLOATING_ALLOCATION_POOL="vlan interval" 
 MULTI_HOST=1
 IMAGE_URLS+="..."
 Q_USE_SECGROUP=True
 Q_USE_PROVIDERNET_FOR_PUBLIC=True
 PROVIDER_NETWORK_TYPE=vlan
 Q_PLUGIN=ml2 OVS_PHYSICAL_BRIDGE=br-ex
 PUBLIC_BRIDGE=br-ex
 OVS_BRIDGE_MAPPINGS=public:br-ex

This is a snippet of local configuration of one of the compute nodes:

SERVICE_HOST="controller-vlan-address"
MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
GLANCE_HOSTPORT=$SERVICE_HOST:9292
MULTI_HOST=1 PUBLIC_INTERFACE=eno1
ENABLED_SERVICES=q-agt,n-cpu,n-cond,placement-api,n-novnc
NOVA_VNC_ENABLED=True
NOVNCPROXY_URL="http://"public-ip":6080/vnc_auto.html"
VNCSERVER_LISTEN="host-ip"
VNCSERVER_PROXYCLIENT_ADDRESS=$VNCSERVER_LISTEN PROVIDER_NETWORK_TYPE=vlan

Stack of controller and compute nodes finished without errors, but when I try to assign a floating ip (which is one from the vlan pool) to a spawned virtual machine scheduled on compute node that machine is unreachable. I've followed the multinode lab guide adding just PROVIDER_NET=vlan for compute nodes. What I've to change in my configuration?

edit retag flag offensive close merge delete