Ask Your Question
0

Error On Instance Start

asked 2013-05-12 10:25:36 -0500

greyfox55 gravatar image

updated 2013-05-21 00:48:05 -0500

smaffulli gravatar image

Hi,

I am new to OpenStack and looking into it as a possible replacement of VMWare ESXi. I followed this guide https://github.com/mseknibilel/OpenStack-Grizzly-Install-Guide/blob/master/OpenStackGrizzlyInstall_Guide.rst. Everything seems to have installed and been configured correctly. I got to the dashboard with no problem but I can't start any instances. They immediately go into the error state. In the nova-scheduler I see:

 2013-05-16 10:07:26.356 WARNING nova.scheduler.driver [req-86b792ed-542e-438d-a969-079c42a6297f 6d0fc01e803447a681b4cce6efb11b5b 364bca98308f406c828d870aa84d038b] [instance: 0a7a79fd-28e7-4e32-ac85-4b9e4e001e28] Setting instance to ERROR state.

I have no idea where to start looking. Can someone point me in the right direction?

edit retag flag offensive close merge delete

Comments

1

On the controller node check: /var/log/nova/nova-api.log and /var/log/nova/nova-scheduler.log

On the compute node: /var/log/nova/nova-compute.log

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-05-12 11:13:49 -0500 )edit

Thanks, this is what I am seeing in nova-scheduler

2013-05-16 10:07:26.356 WARNING nova.scheduler.driver [req-86b792ed-542e-438d-a969-079c42a6297f 6d0fc01e803447a681b4cce6efb11b5b 364bca98308f406c828d870aa84d038b] [instance: 0a7a79fd-28e7-4e32-ac85-4b9e4e001e28] Setting instance to ERROR state.

greyfox55 gravatar imagegreyfox55 ( 2013-05-16 12:03:03 -0500 )edit

Are there any preceding messages that give a reason?

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-05-16 13:32:02 -0500 )edit

I found something in nova-compute.log, was to big to fit in comment so posted below.

greyfox55 gravatar imagegreyfox55 ( 2013-05-17 20:46:27 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2013-05-17 20:15:33 -0500

greyfox55 gravatar image

updated 2013-05-21 00:45:12 -0500

smaffulli gravatar image

Actually I resolved the issue. There was an issue with my /etc/init/libvirt-bin.conf file. Thanks for all your help pointing me in the right direction.

I may have found something in the /var/log/nova/nova-compute.log

This is from the log when I restart the nova-compute service

2013-05-17 21:13:51.016 25392 INFO nova.manager [-] Skipping periodic task _periodic_update_dns because its interval is negative
2013-05-17 21:13:51.074 25392 INFO nova.virt.driver [-] Loading compute driver 'libvirt.LibvirtDriver'
2013-05-17 21:13:51.154 INFO nova.openstack.common.rpc.common [req-113f7b87-2937-4f74-8429-58fd0e46ac72 None None] Connected to AMQP server on 10.10.2.3:5672
2013-05-17 21:13:51.177 25392 AUDIT nova.service [-] Starting compute node (version 2013.1)
2013-05-17 21:13:51.184 25392 ERROR nova.virt.libvirt.driver [-] Connection to libvirt failed: Failed to connect socket to '/var/run/libvirt/libvirt-sock': No such file or directory
2013-05-17 21:13:51.184 25392 TRACE nova.virt.libvirt.driver Traceback (most recent call last):
2013-05-17 21:13:51.184 25392 TRACE nova.virt.libvirt.driver   File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py", line 627, in _connect
2013-05-17 21:13:51.184 25392 TRACE nova.virt.libvirt.driver     return libvirt.openAuth(uri, auth, 0)
2013-05-17 21:13:51.184 25392 TRACE nova.virt.libvirt.driver   File "/usr/lib/python2.7/dist-packages/libvirt.py", line 102, in openAuth
2013-05-17 21:13:51.184 25392 TRACE nova.virt.libvirt.driver     if ret is None:raise libvirtError('virConnectOpenAuth() failed')
2013-05-17 21:13:51.184 25392 TRACE nova.virt.libvirt.driver libvirtError: Failed to connect socket to '/var/run/libvirt/libvirt-sock': No such file or directory
2013-05-17 21:13:51.184 25392 TRACE nova.virt.libvirt.driver
2013-05-17 21:13:51.189 25392 WARNING nova.virt.libvirt.driver [-] URI qemu:///system does not support events
2013-05-17 21:13:51.190 25392 ERROR nova.virt.libvirt.driver [-] Nova requires libvirt version 0.9.6 or greater.
2013-05-17 21:13:51.217 25392 ERROR nova.virt.libvirt.driver [-] Connection to libvirt failed: Failed to connect socket to '/var/run/libvirt/libvirt-sock': No such file or directory
2013-05-17 21:13:51.217 25392 TRACE nova.virt.libvirt.driver Traceback (most recent call last):
2013-05-17 21:13:51.217 25392 TRACE nova.virt.libvirt.driver   File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/driver.py", line 627, in _connect
2013-05-17 21:13:51.217 25392 TRACE nova.virt.libvirt.driver     return libvirt.openAuth(uri, auth, 0)
2013-05-17 21:13:51.217 25392 TRACE nova.virt.libvirt.driver   File "/usr/lib/python2.7/dist-packages/libvirt.py", line 102, in openAuth
2013-05-17 21:13:51.217 25392 TRACE nova.virt.libvirt.driver     if ret is None:raise libvirtError('virConnectOpenAuth() failed')
2013-05-17 21:13:51.217 25392 TRACE nova.virt.libvirt.driver libvirtError: Failed to connect socket to '/var/run/libvirt/libvirt-sock': No such file or directory
2013-05-17 21:13:51.217 25392 TRACE nova.virt.libvirt.driver
2013-05-17 21:13:51.219 WARNING ...
(more)
edit flag offensive delete link more

Comments

How you resolved this, I'm getting the same problem. What you did with /etc/init/libvirt-bin.conf file?

vishgarg gravatar imagevishgarg ( 2014-10-15 00:04:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-05-12 10:25:36 -0500

Seen: 2,364 times

Last updated: May 21 '13