Ask Your Question
1

Error: Unable to retrieve the flavors. (IE only)

asked 2017-03-07 15:37:33 -0500

jep gravatar image

updated 2017-03-10 09:14:51 -0500

I'm getting the error message "Error: Unable to retrieve the flavors." in the dashboard when I try to Launch a new Instance. The problem started after the upgrade from newton to ocata.

Everything else seems to be working correctly. I can list the flavors through command line (openstack flavor list), and I see the flavors though the admin dashboard. I can add and remove flavors, too.

I don't see any errors in the nova or keystone logs. It's really odd that when I try to launch a new instance and get the error, the nova-api log shows queries to get os-keypairs, limits, os-availability-zone, os-server-groups, but nothing for flavors.

I don't know where else to look. Any help is greatly appreciated.

edit retag flag offensive close merge delete

Comments

It may beacuse under which tenant you are trying to launch an instance may not have permisson to access flavor.

amitabh sinha gravatar imageamitabh sinha ( 2017-03-07 23:36:40 -0500 )edit

Might be a bug specific to DevStack: https://bugs.launchpad.net/devstack/+...

Bernd Bausch gravatar imageBernd Bausch ( 2017-03-07 23:54:16 -0500 )edit

I checked flavor permissions. I even tried assigning specific permissions to the flavors. Still the same problem. As for that bug report, it describes my issue very accurately, even though I didn't use devstack. I installed openstack using the Installation Guides. Is there any solution / workaround?

jep gravatar imagejep ( 2017-03-08 08:14:20 -0500 )edit

I just saw a comment in the devstack bug report, stating this error happens in IE only. I just tried firefox and the error message did not show up. Flavors were listed and I was able to launch a new instance. So this behavior occurs in IE only.

jep gravatar imagejep ( 2017-03-09 13:40:27 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-10-06 09:08:09 -0500

jep gravatar image

I can confirm that this problem was fixed in Pike.

edit flag offensive delete link more
0

answered 2017-06-29 01:41:42 -0500

Vinoth gravatar image

I am facing the same issue! Hitting only in I.E

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

3 followers

Stats

Asked: 2017-03-07 15:37:33 -0500

Seen: 695 times

Last updated: Oct 06