Ask Your Question
0

Packstack: Route to external network disappeared after rebooting controller

asked 2017-03-07 04:17:39 -0500

Bernd Bausch gravatar image

updated 2017-03-07 19:35:21 -0500

On my Newton-based Packstack (all-in-one controller plus two compute nodes), the controller has this route:

$ ip r
...
172.24.4.224/28 dev br-ex  proto kernel  scope link  src 172.24.4.225

All is fine there.

I also deployed an Ocata-based Packstack. After rebooting the controller, I can't access instances through their floating IPs anymore, and indeed, there is no route to 172.24.4.xxx.

I can't confirm that this route existed before, but I see traces in the deployment log file /var/tmp/packstack/latest/openstack-setup.log:

# grep openstack-setup.log
...
ipaddress => 172.24.4.1
ipaddress_br_ex => 172.24.4.1
network_br_ex => 172.24.4.0
2017-03-07 15:40:12::DEBUG::run_setup::626::root:: provision-demo-floatrange: 172.24.4.0/24

My networking skills are not sufficient to figure out where this route disappeared. Any idea where to look?

EDIT: I provisioned a new Packstack controller.

This time, I removed the superfluous eth1 from the controller. As recommended on the quickstart page, firewalld and NW manager disabled, network service enabled. Packstack provisioned like this:

sudo packstack -d --default-password=bla --allinone

Directly after installation, I have no ifcfg-br-ex, but this route exists:

172.24.4.0/24 dev br-ex  proto kernel  scope link  src 172.24.4.1

And:

4: br-ex: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN qlen 1000
    link/ether 5a:9d:96:0b:ed:48 brd ff:ff:ff:ff:ff:ff
    inet 172.24.4.1/24 scope global br-ex
       valid_lft forever preferred_lft forever

After rebooting, no route to 172, and:

9: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 5a:9d:96:0b:ed:48 brd ff:ff:ff:ff:ff:ff

After ip link set br-ex up and adding the IP address manually, I can access my instance via floating IP. So I do have a good workaround, but somewhere in Packstack the setup of br-ex is not quite watertight.

I submitted a bug description.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-03-07 06:29:09 -0500

dbaxps gravatar image

I presume that there is real Network in the lab with CIDR 172.24.4.225/28 ( provision demo is "y" ) Then on Network Node :-

[root@ip-192-169-142-147 network-scripts]# cat ifcfg-br-ex
DEVICE="br-ex"
BOOTPROTO="static"
IPADDR="172.24.4.229"
NETMASK="255.255.255.240"
DNS1="83.221.202.254"
BROADCAST="172.24.4.239"
GATEWAY="172.24.4.225"  <== IP Physical Router in LAB
NM_CONTROLLED="no"
TYPE="OVSIntPort"
OVS_BRIDGE=br-ex
DEVICETYPE="ovs"
DEFROUTE="yes"
IPV4_FAILURE_FATAL="yes"
IPV6INIT=no

[root@ip-192-169-142-147 network-scripts]# cat ifcfg-eth2
DEVICE="eth2"
ONBOOT="yes"
TYPE="OVSPort"
DEVICETYPE="ovs"
OVS_BRIDGE=br-ex
NM_CONTROLLED=no
IPV6INIT=no

Next step to performed on Network Node :-

# chkconfig network on
# systemctl stop NetworkManager
# systemctl disable NetworkManager
# service network restart

IF your real external network is for instance 192.168.0.0/24 && Router IP is 192.168.0.1 update ifcfg-br-ex and ifcfg-eth2 accordingly. OVS database without ifcfg-* files won't support persistent external OVS bridge and OVS port eth2

image description

edit flag offensive delete link more

Comments

I need a night's sleep before I can process this.

Bernd Bausch gravatar imageBernd Bausch ( 2017-03-07 08:10:38 -0500 )edit

Sure, take your time :)

dbaxps gravatar imagedbaxps ( 2017-03-07 08:32:50 -0500 )edit

Thanks Boris, but my "external" network is not mapped to outside. provision-demo=y only means that the private network and the router for the demo project are created. It's a default setting, by the way.

I removed eth1 and tried again. Question updated with result.

Bernd Bausch gravatar imageBernd Bausch ( 2017-03-07 19:07:09 -0500 )edit

I guess that by creating an ifcfg-br-ex similar to your suggestion, I should be fine.

Bernd Bausch gravatar imageBernd Bausch ( 2017-03-07 19:37:15 -0500 )edit
dbaxps gravatar imagedbaxps ( 2017-03-08 03:02:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-03-07 04:17:39 -0500

Seen: 251 times

Last updated: Mar 07