Ask Your Question
0

HTTPInternalServerError (HTTP 500) - glance on separate server

asked 2017-03-03 12:57:44 -0500

holo gravatar image

updated 2017-03-03 17:45:39 -0500

Hello

I'm configuring openstack according to: https://docs.openstack.org/ocata/inst...

I installed keystone on one instance and want to install glance on separate server, when im trying to verify my configuration im getting:

[root@manage01 ~]# openstack image create "cirros"   --file cirros-0.3.4-x86_64-disk.img   --disk-format qcow2 --container-format bare   --public
HTTPInternalServerError (HTTP 500)
[root@manage01 ~]# openstack -v image create "cirros"   --file cirros-0.3.4-x86_64-disk.img   --disk-format qcow2 --container-format bare   --public
START with options: [u'-v', u'image', u'create', u'cirros', u'--file', u'cirros-0.3.4-x86_64-disk.img', u'--disk-format', u'qcow2', u'--container-format', u'bare', u'--public']
command: image create -> openstackclient.image.v2.image.CreateImage
Using auth plugin: password
HTTPInternalServerError (HTTP 500)
END return value: 1

My present endpoints configuration:

[root@manage01 ~]# openstack endpoint list
+----------------------------------+-----------+--------------+--------------+---------+-----------+---------------------------+
| ID                               | Region    | Service Name | Service Type | Enabled | Interface | URL                       |
+----------------------------------+-----------+--------------+--------------+---------+-----------+---------------------------+
| 94f2b772504042d380fb6b2779d7b513 | RegionOne | glance       | image        | True    | internal  | http://image:9292         |
| 97e549d381604224ad742b718b833d02 | RegionOne | glance       | image        | True    | public    | http://image:9292         |
| 9f3ee12b68bd449f84150c2a8a4a2340 | RegionOne | keystone     | identity     | True    | public    | http://identity:5000/v3/  |
| a1ccaa525b6a48549a79017388354204 | RegionOne | glance       | image        | True    | admin     | http://image:9292         |
| bf47ca0119a94a07b6f5acece8a5b699 | RegionOne | keystone     | identity     | True    | admin     | http://identity:35357/v3/ |
| c62838c2471e4624a3e7f5c3bc5fdf38 | RegionOne | keystone     | identity     | True    | internal  | http://identity:5000/v3/  |
+----------------------------------+-----------+--------------+--------------+---------+-----------+---------------------------+

What am i missed? If i do everything exectly same way but on same server where i have keystone configured glance is working. Should i change some other configuration too which is not mentioned in standard installation?

Connection betwenn instances is working (separate VLAN for mgmt network).

Regards holo

edit retag flag offensive close merge delete

Comments

Check the glance-api log file for more info about the error. One possible error: Glance might have no access to the database.

Bernd Bausch gravatar imageBernd Bausch ( 2017-03-03 17:49:10 -0500 )edit

In glance log is onlly info about service start nothing more. During installation i needed to sync DB and tables are created so glance have connection to database.During operation i see only new logs in keystone log and nothing more (no errors).

holo gravatar imageholo ( 2017-03-04 05:13:02 -0500 )edit

Run the command with the --debug option. I wonder what part of OpenStack issues the http 500. If it's Glance, why is there nothing in the log? If not, what other component generates the message?

By the way, when you create the database, you don't do it through the Glance service.

Bernd Bausch gravatar imageBernd Bausch ( 2017-03-04 06:06:42 -0500 )edit

Here it is: http://pasted.co/999f47de

Database was create manually and then i used command from docs to create tables:

su -s /bin/sh -c "glance-manage db_sync" glance
holo gravatar imageholo ( 2017-03-04 06:37:58 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-03-04 06:48:52 -0500

holo gravatar image

updated 2017-03-04 07:25:03 -0500

There was not python-memcached module installed on glance server. I missed that information actually appear in glance log. Now glance service is working. Thank you for your time and sorry - my fault.

PS It could be good to add python-memcached as dependency for glance and other services too, not only for keystone in case of installation on separate instances.

edit flag offensive delete link more

Comments

Most probably memcached is not a hard requirement. I would guess that other mechanisms can be configured for caching information. For example, you see it mentioned in the sample glance-api.conf file.

Bernd Bausch gravatar imageBernd Bausch ( 2017-03-04 19:36:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-03-03 12:57:44 -0500

Seen: 240 times

Last updated: Mar 04 '17