Ask Your Question
0

why memcached cann't be enabled in dashboard

asked 2017-03-03 11:12:07 -0500

yan gravatar image

updated 2017-03-03 11:12:41 -0500

I am installing Openstack of Mitaka and Centos7.

When I add SESSION_ENGINE = 'django.contrib.sessions.backends.cache' in localsetting file as the installation file mentioned, I can't access the website of Openstack, the erros is as below: "Unable to create a new session key. " [Fri Mar 03 16:29:22.382562 2017] [:error] [pid 28850] RuntimeError: Unable to create a new session key. It is likely that the cache is unavailable.

but if I remove it, I can access the website by webrowsers but the speed is slow becausse no cache I guess, I want to know why? Thanks!

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-03-07 16:23:56 -0500

jep gravatar image

Check that memcached is actually running, and that it's listening on the correct IP (OPTIONS="-l ....) Also, did you update the CACHES section in local_settings?

CACHES = {
    'default': {
         'BACKEND': 'django.core.cache.backends.memcached.MemcachedCache',
         'LOCATION': 'controller:11211',
    }
edit flag offensive delete link more

Comments

Thanks! I really config the caches and session according to installation document, so the configuration of caches is right, the service of httpd and memcached are all good, but it really doesn't work!

yan gravatar imageyan ( 2017-03-08 11:37:27 -0500 )edit
0

answered 2017-03-08 11:53:51 -0500

yan gravatar image

modify /etc/sysconfig/memcached -l 127.0.0.1 to management ip address of controller to solve it!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-03-03 11:12:07 -0500

Seen: 305 times

Last updated: Mar 08 '17