Ask Your Question
0

Router management not available in dashboard

asked 2017-03-02 10:10:58 -0500

ICBeter gravatar image

Hello,

I set up a test installation of Openstack following the Online-Guide.

I created a router as described in the Guide. But in the dashboard it is not visible. Even the whole "Router" section is missing in the menu on the left. So there is also no "create router" available.

As I set up this installation for students learning the basics of Openstack without having shell access (that will come later), I need all this functionality in the dashboard.

I did not find any hints in the log files. Any ideas what could be wrong?

Thanks, Peter

openstack-no-router.png

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-03-02 10:32:14 -0500

Check if the name space got created or not.

In controller type ip netns and there should be a namespace for router if not please make sure you follow the neutron installation steps properly and configured L3 agent.

Also double check you are installing a self service network instead of a Provider network

http://www.stackguy.com

edit flag offensive delete link more

Comments

yes, there is a namespace. And with cmdline tools I also see the router!

controller:~$ ip netns
qrouter-234fb5fd-518a-4271-99bb-ddfdd776fb35 (id: 2)
qdhcp-d53cae93-9b52-4363-bb18-395b6b9a8ac3 (id: 1)
qdhcp-b856defb-9cbb-4852-b654-80897c76f125 (id: 0)

controller:~$ neutron router-list
+--------------------------------------+--------+-------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| id                                   | name   | external_gateway_info                                                                                                                                             |
+--------------------------------------+--------+-------------------------------------------------------------------------------------------------------------------------------------------------------------------+
| 234fb5fd-518a-4271-99bb-ddfdd776fb35 | router | {"network_id": "b856defb-9cbb-4852-b654-80897c76f125", "enable_snat": true, "external_fixed_ips": [{"subnet_id": "bedb6b3f-a88a-4434-ba2e-564fa6fd4ab0",          |
|                                      |        | "ip_address": "172.16.255.2"}]}                                                                                                                                   |
+--------------------------------------+--------+-------------------------------------------------------------------------------------------------------------------------------------------------------------------+
ICBeter gravatar imageICBeter ( 2017-03-03 09:02:30 -0500 )edit

Verify the below steps

1) What about the status of neutron-l3-agent neutron agent-list.Does it show active?. 2) Are you able to ping router Gateway from Instance ,Is the IP reachable?. 3)Check out outputs for neutron ext-list and check if the extensions are added properly .

http://stackguy.com

stackguy gravatar imagestackguy ( 2017-03-03 09:55:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-03-02 10:10:58 -0500

Seen: 37 times

Last updated: Mar 02