Ask Your Question
0

changing scheduler_max_attempts nova.conf does not affect anything

asked 2017-02-27 19:31:18 -0500

rohanil gravatar image

I want to reduce scheduler_max_attempts in nova.conf. I changed it and restarted nova-scheduler service. Then I tried to test the change by triggering multiple vm creation at the same time. I could see that there are more number of retries happen than I set for scheduler_max_attempts. I want to know if any other service needs restart to apply scheduler_max_attempts change.

edit retag flag offensive close merge delete

Comments

Looking at the source, I think it's only the scheduler. Note that this parameter limits the number of times a given failed instance is rescheduled. Is that what you understand?

Bernd Bausch gravatar imageBernd Bausch ( 2017-02-28 03:11:37 -0500 )edit

Yes I understand that. I have experienced the cases when this number is not enough and it raises error. So I want to increase this number.

rohanil gravatar imagerohanil ( 2017-03-29 20:54:29 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-03-29 20:55:16 -0500

rohanil gravatar image

I got it working after restarting nova-conductor.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-02-27 19:31:18 -0500

Seen: 77 times

Last updated: Mar 29 '17