Ask Your Question
0

neutron + pep8 failure on latest code

asked 2014-01-10 20:03:25 -0500

rms_13 gravatar image

updated 2015-10-13 08:51:11 -0500

fifieldt gravatar image

I cloned latest neutron on ubuntu 12.04 machine and tried to run tox -e pep8 and it failed with following error:

Downloading/unpacking psutil>=0.6.1,<1.0 (from -r /opt/stack/neutron/requirements.txt (line 19)) Could not find a version that satisfies the requirement psutil>=0.6.1,<1.0 (from -r /opt/stack/neutron/requirements.txt (line 19)) (from versions: 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.2.0, 1.2.1) Some externally hosted files were ignored (use --allow-external to allow). Cleaning up... No distributions matching the version for psutil>=0.6.1,<1.0 (from -r /opt/stack/neutron/requirements.txt (line 19)) Storing debug log for failure in /root/.pip/pip.log Command "tools/with_venv.sh pip install --upgrade -r /opt/stack/neutron/requirements.txt" failed.

Anyone has face this or know whats wrong? Thanks in advance for the response.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-01-20 12:57:37 -0500

jmeridth gravatar image

updated 2014-01-21 09:26:49 -0500

I had to create ~/.pip/pip.conf with:

[global]
index-url =  <a href="http://pypi.openstack.org/openstack">http://pypi.openstack.org/openstack</a>  
extra-index-url =  <a href="http://pypi.openstack.org/openstack-infra">http://pypi.openstack.org/openstack-i...</a> 
use-mirrors = True
timeout = 60
[install]
download-cache=~/.pip/download-cache

The key is to point your pip indexes at http://pypi.openstack.org I was unable to get it to work with only http://pypi.openstack.org . Had to specifically reference the subfolders openstack and openstack-infra

edit flag offensive delete link more
0

answered 2014-01-13 03:59:39 -0500

darragh-oreilly gravatar image

What version of pip are you using? You may be seeing this if it is >=1.5. There is a fix review in progress here.

edit flag offensive delete link more

Comments

pip 1.4.1 from /usr/local/lib/python2.7/dist-packages/pip-1.4.1-py2.7.egg (python 2.7) This is what I am using.

rms_13 gravatar imagerms_13 ( 2014-01-13 11:53:19 -0500 )edit
1

So to workaround it until a proper fix is merged, change the line "psutil>=0.6.1,<1.0" to "psutil>=0.6.1" in requirements.txt.

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-01-14 04:12:01 -0500 )edit

darragh-oreilly's comment fixed it for me. I had a similar experience with tempest and the 'netaddr' package before, the temporary workaround there involves downgrading netaddr from '>=0.7.6' to '>=0.7.3'.

jroovers gravatar imagejroovers ( 2014-01-17 15:48:36 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-10 20:03:25 -0500

Seen: 288 times

Last updated: Jan 21 '14