Ask Your Question
0

Kolla AIO deploy fail: Hostname has to resolve IP address ?

asked 2017-02-25 13:23:40 -0500

harish23r gravatar image

updated 2017-02-25 13:37:11 -0500

I'm trying to deploy Kolla in AIO.
I build images using the command: kolla-build -p default -b ubuntu -t binary
I am deploying it in my local system. I'm using ubuntu 16.04, built images. I'm not using a local registry.

kolla-ansible precheck runs fine

kolla-ansible deploy gives me an error while starting rabbitmq
My host name is DESKTOP
The output of hosts file
cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 DESKTOP

::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

The error is as follows
TASK: [rabbitmq | fail msg="Hostname has to resolve to IP address of api_interface"] * failed: [localhost] => (item={u'cmd': [u'getent', u'ahostsv4', u'DESKTOP'], u'end': u'2017-02-26 00:45:10.399323', u'stderr': u'', u'stdout': u'127.0.1.1 STREAM DESKTOP\n127.0.1.1 DGRAM \n127.0.1.1 RAW ', u'changed': False, u'rc': 0, 'item': 'localhost', u'warnings': [], u'delta': u'0:00:00.001585', 'invocation': {'module_name': u'command', 'module_complex_args': {}, 'module_args': u'getent ahostsv4 DESKTOP'}, 'stdout_lines': [u'127.0.1.1 STREAM DESKTOP', u'127.0.1.1 DGRAM ', u'127.0.1.1 RAW '], u'start': u'2017-02-26 00:45:10.397738'}) => {"failed": true, "item": {"changed": false, "cmd": ["getent", "ahostsv4", "DESKTOP"], "delta": "0:00:00.001585", "end": "2017-02-26 00:45:10.399323", "invocation": {"module_args": "getent ahostsv4 DESKTOP", "module_complex_args": {}, "module_name": "command"}, "item": "localhost", "rc": 0, "start": "2017-02-26 00:45:10.397738", "stderr": "", "stdout": "127.0.1.1 STREAM DESKTOP\n127.0.1.1 DGRAM \n127.0.1.1 RAW ", "stdout_lines": ["127.0.1.1 STREAM DESKTOP", "127.0.1.1 DGRAM ", "127.0.1.1 RAW "], "warnings": []}} msg: Hostname has to resolve to IP address of api_interface

FATAL: all hosts have already failed -- aborting

PLAY RECAP ********************** to retry, use: --limit @/home/ravichandran/site.retry

localhost : ok=84 changed=11 unreachable=0 failed=1

Please help.

edit retag flag offensive close merge delete

Comments

I'm seeing a typo in /etc/hosts, is using 127.0.1.1 instead of 127.0.0.1. Also, hostname expects to be resolvable from the IP of network_interface variable.

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-02-26 05:15:40 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-02-25 21:28:33 -0500

Never point your hostname at 127.0.0.1 thats basic linux mistake. Point to addr on your interface.

edit flag offensive delete link more

Comments

I don't seem to get your answer. Linux by deafult maps 127.0.0.1 to localhost. ?

harish23r gravatar imageharish23r ( 2017-02-26 00:33:28 -0500 )edit

And what should I change here? How to point address on the interface?

harish23r gravatar imageharish23r ( 2017-02-26 00:33:58 -0500 )edit

Add in /etc/hosts.

YOUR_IP hostname

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-02-26 05:17:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-02-25 13:23:40 -0500

Seen: 72 times

Last updated: Feb 25