Ask Your Question
1

No routing to physnet1 kolla-ansible

asked 2017-02-22 19:43:01 -0500

Rafael Almeida gravatar image

updated 2017-02-23 05:42:43 -0500

Hi, I'd deployed a multi node openstack with kolla ansible. Host01: Controller + Network. Host02-05 Compute.

All hosts have two NICs eth0 with ip form my local network and eth1 UP without ip.

So i've configured my exernal network on physnet1. And a private network. Then create a router. Everithing seems ok. But my router does not ping to gateway of my exernal network.

After create router i've seem a new port of my external network that is been used by router. But its not pingable.

Some points already checked. Security Groups are all open UDP + ICMP + TCP.

From my external network nmap found my router ip but all ports are filtered.

Float ip does not reachable too.

Controller/Network Node ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 00:0c:29:89:ee:9c brd ff:ff:ff:ff:ff:ff
    inet 10.10.0.199/24 brd 10.10.0.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet 10.10.0.254/32 scope global eth0
       valid_lft forever preferred_lft forever
    inet 232.178.15.100/32 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::20c:29ff:fe89:ee9c/64 scope link 
       valid_lft forever preferred_lft forever

3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master ovs-system state UP qlen 1000
    link/ether 00:0c:29:89:ee:a6 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::20c:29ff:fe89:eea6/64 scope link 
       valid_lft forever preferred_lft forever

4: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN 
    link/ether 02:42:f5:7a:8d:92 brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 scope global docker0
       valid_lft forever preferred_lft forever

5: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 6a:dd:ca:9b:95:95 brd ff:ff:ff:ff:ff:ff

6: br-tun: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether da:26:d1:9b:dc:45 brd ff:ff:ff:ff:ff:ff

8: br-int: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether f6:6f:dd:a4:ef:46 brd ff:ff:ff:ff:ff:ff

12: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether 00:0c:29:89:ee:a6 brd ff:ff:ff:ff:ff:ff

Router ns ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1 ...
(more)
edit retag flag offensive close merge delete

Comments

Can you paste content of:

docker exec openvswitch_db ovs vsctl-show
/etc/kolla/globals/yml

Why eth0 have 3 IP addresses, guess is one for access, other for HAproxy VIP, the other? If you want can came to #openstack-kolla IRC channel and ask there

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-02-23 05:20:16 -0500 )edit

Hi Eduardo,

01 for acces, 01 private VIP + 01 Public VIP

Rafael Almeida gravatar imageRafael Almeida ( 2017-02-23 05:43:29 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-05-20 11:45:44 -0500

shotoflove gravatar image

If you're in a virtual environment, try to make sure your external nic is allow all traffic inside virtualbox. E.g., Promisicious Mode "Allow All" under advanced settings.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-02-22 19:43:01 -0500

Seen: 285 times

Last updated: Feb 23 '17