# openstack image list -- Service Unavailable

asked 2017-02-21 22:03:11 -0500

Zahid haseeb gravatar image

# openstack image list Service Unavailable (HTTP 503)

# openstack image list Service Unavailable (HTTP 503)

/var/log/glance/api.log 2017-02-19 21:14:58.042 2647 WARNING keystonemiddleware.auth_token [-] Identity response: {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}} 2017-02-19 21:14:58.295 2647 WARNING keystonemiddleware.auth_token [-] Identity response: {"error": {"message": "The request you have made requires authentication.", "code": 401, "title": "Unauthorized"}} 2017-02-19 21:14:58.303 2647 CRITICAL keystonemiddleware.auth_token [-] Unable to validate token: Identity server rejected authorization necessary to fetch token data 2017-02-19 21:14:58.333 2647 INFO eventlet.wsgi.server [-] 10.0.0.11 - - [19/Feb/2017 21:14:58] "GET /v2/images HTTP/1.1" 503 259 0.622471

edit retag flag offensive close merge delete

Comments

It seems authentication for Glance is not set up correctly, in the [keystone_authtoken] section of the glance-api.conf file. The install guide has an example for a successful configuration.

Bernd Bausch gravatar imageBernd Bausch ( 2017-02-22 01:32:12 -0500 )edit

I used correct password under [keystone_authtoken] section of the glance-api.conf file. Furthermore I followed the same example guide which you suggested. Below keystone_authtoken section configuration(for username & password) is for your reference.

username = glance password = xxxxxxxxxx

Zahid haseeb gravatar imageZahid haseeb ( 2017-02-22 02:59:33 -0500 )edit

I restarted the system and things working fine. Below is for reference.Could not understand what happened.

openstack image list

+--------------------------------------+--------+--------+ | ID | Name | Status | +--------------------------------------+--------+---

Zahid haseeb gravatar imageZahid haseeb ( 2017-02-22 03:27:56 -0500 )edit