Ask Your Question
1

br100 setup and nova fixed ip range

asked 2013-05-12 05:04:17 -0500

polslinux gravatar image

updated 2013-06-11 10:15:41 -0500

fifieldt gravatar image

This is my situation:

  • An ESXi 5.0 Server (I'm doing a project for my BD);
  • A pool with 2 VM (1 controller node and 1 compute node)
  • Ubuntu 13.04 amd64 Server installed on both VM
  • The controller IP is 172.25.27.11
  • i've successfully setup keystone, glance and partially nova

My problem with nova is the creation of the br100 and the fixed range subnet. Inside the /etc/network/interfaces file i have:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto br100
iface br100 inet dhcp
bridge_ports eth0
bridge_stp off
bridge_fd 0
bridge_maxwait 0

inside the file /etc/nova/nova.conf i have:

# NETWORK
network_manger_nova=nova.network.manger.FlatDHCPManager
my_ip=172.25.27.11
fixed_range=172.25.27.0/24
public_interface=eth0
vlan_interface=eth0
flat_interface=eth0
flat_network_bridge=br100

I have also enabled ip forwarding inside /etc/sysctl.conf and i have set eth0 promisc with ip link set eth0 promisc on.

The cmd brctl show show:

bridge name      bridge id    STP enabled        interfaces
br100            8000.xxxx    no                 eth0

What i am doing wrong?

edit retag flag offensive close merge delete

Comments

1
Alen Komljen gravatar imageAlen Komljen ( 2013-05-12 05:36:50 -0500 )edit

on the controller node have i to write br100 ecc ecc inside etc/network/interfaces ??

polslinux gravatar imagepolslinux ( 2013-05-12 07:35:43 -0500 )edit

No, just on compute node.

Alen Komljen gravatar imageAlen Komljen ( 2013-05-12 07:40:09 -0500 )edit

thanks, you've solved my problem :D :D

polslinux gravatar imagepolslinux ( 2013-05-12 07:46:39 -0500 )edit

ps last thing: eth0 have to be set "promisc on" or off?

polslinux gravatar imagepolslinux ( 2013-05-12 07:47:34 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2013-05-13 08:25:57 -0500

epillet gravatar image

Hi

I think you should configure the adress on br100 as well, like this :

iface br100 inet static
    address 172.25.27.11
    netmask 255.255.255.0
    bridge_stp off
    bridge_fd 0

Could you also check without this :

bridge_ports eth0

If you are not sure of the upper lines, what do you get from this ?

#ifdown -a; ifup -a;

Could you also try to create the fixed network with this command ?

nova network-create private --fixed-range-v4=172.25.27.0/24 --bridge-interface=br100

Sources :

edit flag offensive delete link more

Comments

i don't understand anthing xD have or don't have to write iface br100 ecc ecc on the controlloer node??

polslinux gravatar imagepolslinux ( 2013-05-15 04:39:31 -0500 )edit

Alen Komljen seems to believe it would correct your problem, and you said it did. As the question wasn't closed, I didn't see his answer at first, so I posted another possibility. But, once more, if everything is ok with his answer, no use to change anything !

epillet gravatar imageepillet ( 2013-05-16 02:04:00 -0500 )edit
1

answered 2013-07-12 02:23:00 -0500

jacky velluet gravatar image

Hello,

You have write "network_manger_nova=nova.network.manger.FlatDHCPManager" I think this is "network_manager_nova=nova.network.manager.FlatDHCPManager"

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-05-12 05:04:17 -0500

Seen: 5,715 times

Last updated: Jul 12 '13