Ask Your Question
0

How to enable LBAAS in Horizon - packstack

asked 2017-02-21 03:23:59 -0600

razvlix gravatar image

Hello,

I am using Packstack Newton with 1 controller and 2 compute nodes. I deployed using the answer file with LBAAS and FWAAS. From the Horizon Portal I can see the Firewall under Compute-> NEtwork but cannot see Load Balancer.

I already set it to "True" in /etc/openstack-dashboard/local_settings

OPENSTACK_NEUTRON_NETWORK = { 'enable_distributed_router': False, 'enable_firewall': True, 'enable_ha_router': False, 'enable_lb': True,

but I dont see it in Horizon.

Any ideas?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-02-24 23:58:15 -0600

Shaik Saddam Hussain gravatar image

Hi,

Please follow below process,

lbaas v2 activiation

  1. The following command will update neutron mariaDB with lbaas tables. neutron-db-manage --service lbaas --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/ml2_conf.ini upgrade head

  2. go to vim /etc/neutron/neutron_lbaas.conf in "service providers" section, commentout (#) all except service_provider=LOADBALANCERV2:Haproxy:neutron_lbaas.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default

  3. go to vim /etc/neutron/neutron.conf make sure that in the "service_plugins" section you see "neutron_lbaas.services.loadbalancer.plugin.LoadBalancerPluginv2" (not only this, it is possible that you will see other plugins you enabled in answerfile)

  4. go to lbaas_agent file (can be in /etc/neutron or /etc/neutron/services/loadbalancer/haproxy/)

add in [DEFAULT] block ovs_use_veth = False add in [haproxy] block user_group = haproxy commentout any "device friver" that is not commented out.

If the l3-agent is in failed mode pls see l3_agent logs- you wil probably need to go to /etc/neutron/neutron.conf and comment-out several values in [DEFAULT] block and uncomment-out same values in "oslo_messaging_rabbit" block and other block - you will see it in the log.

create "/usr/lib/systemd/system/neutron-lbaasv2-agent.service" file (copy "/usr/lib/systemd/system/neutron-lbaas-agent.service" file to "/usr/lib/systemd/system/neutron-lbaasv2-agent.service" file )

edit:

Description=OpenStack Neutron Load Balancing V2 as a Service Agent ExecStart=/usr/bin/neutron-lbaasv2-agent --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/neutron_lbaas.conf --config-file=/etc/neutron/lbaas_agent.ini --log-file /var/log/neutron/lbaasv2-agent.log but with the same flags

systemctl stop neutron-lbaas-agent.service systemctl start neutron-lbaasv2-agent.service

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-02-21 03:23:59 -0600

Seen: 530 times

Last updated: Feb 21 '17