ok_actions is none by autoscaling config [closed]

asked 2017-02-21 02:08:31 -0500

after i deployed the autoscaling by the yaml ,i find the ok_actions is none as follows: root@cic-1:~# ceilometer alarm-list +--------------------------------------+-----------------------------------------+-------+----------+---------+------------+--------------------------------+------------------+ | Alarm ID | Name | State | Severity | Enabled | Continuous | Alarm condition | Time constraints | +--------------------------------------+-----------------------------------------+-------+----------+---------+------------+--------------------------------+------------------+ | 4f62acee-87c4-4d41-9b86-4f81455ba2ce | autoscaling-cpu_alarm_low-uiy5osbr54g5 | alarm | low | True | True | cpu_util < 2.0 during 1 x 100s | None | | 9f46d7d3-3cf5-4052-b113-dcce7d6775a9 | autoscaling-cpu_alarm_high-o32k6ithmohx | ok | low | True | True | cpu_util > 7.0 during 1 x 50s | None | +--------------------------------------+-----------------------------------------+-------+----------+---------+------------+--------------------------------+------------------+

root@cic-1:~# ceilometer alarm-show 4f62acee-87c4-4d41-9b86-4f81455ba2ce +---------------------------+--------------------------------------------------------------------------+ | Property | Value | +---------------------------+--------------------------------------------------------------------------+ | alarm_actions | [u'http://127.0.0.1:8000/v1/signal/arn%3Aopenstack%3Aheat%3A%3Af4be62fa5 | | | e6f4f859d0543682c4ee903%3Astacks%2Fautoscaling%2F17fa1dbc-bcc3-4158 | | | -b90f-958d874935c2%2Fresources%2Fweb_server_scaledown_policy_ssc?Timesta | | | mp=2017-02-17T08%3A25%3A42Z&SignatureMethod=HmacSHA256&AWSAccessKeyId=e9 | | | 452ba2ceef4ae8b911e71a3d2030fc&SignatureVersion=2&Signature=%2FDcSKNQts3 | | | RmxZ1XLES41hq1TTY8%2BCIVzLoligrTvsk%3D'] | | alarm_id | 4f62acee-87c4-4d41-9b86-4f81455ba2ce | | comparison_operator | lt | | description | Scale-down if the average CPU < 15% for 10 minutes | | enabled | True | | evaluation_periods | 1 | | exclude_outliers | False | | insufficient_data_actions | None | | meter_name | cpu_util | | name | autoscaling-cpu_alarm_low-uiy5osbr54g5 | | ok_actions | None | | period | 100 | | project_id | f4be62fa5e6f4f859d0543682c4ee903 | | query | metadata.user_metadata.stack == 17fa1dbc-bcc3-4158-b90f-958d874935c2 | | repeat_actions | True | | severity | low | | state | alarm | | statistic | avg | | threshold | 2.0 | | type | threshold | | user_id | abf60bcb6d8844eb8ea270f3844981a9 | +---------------------------+--------------------------------------------------------------------------+

why the ok_actions is none , the config yaml is as follows:

cpu_alarm_low: type: OS::Ceilometer::Alarm properties: description: Scale-down if the average CPU < 15% for 10 minutes meter_name: cpu_util statistic: avg period: 100 evaluation_periods: 1 threshold: 2 alarm_actions: - {get_attr: [web_server_scaledown_policy_ssc, alarm_url]} - {get_attr: [web_server_scaledown_policy_lc, alarm_url]} matching_metadata: {'metadata.user_metadata.stack': {get_param: "OS::stack_id"}} comparison_operator: lt

who can help me ?

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by zolalee
close date 2017-02-21 02:18:58.411159