Ask Your Question
1

openstack network:router_interface and network:router_gateway down

asked 2017-02-20 14:55:56 -0500

rahuly gravatar image

updated 2017-03-16 14:00:28 -0500

rbowen gravatar image

Hi, I am using devstack and using three server as one Controle node, second Compute node and third for Opendaylight (odl-ovsdb-openstack) ovs management. I have stacked with out any error and have created internal and external respectively. However, I can see on dashboard network :- network:router_interface and network:router_gateway are down. Also not be able to create any instance and the error is: Error: Binding failed for port 9295aa43-9165-4ef4-bd0f-3e602a5bcae0, please check neutron logs for more information.

I have attached screen shot and local.conf

DATA_DIR=/home/stack/stack/data
SERVICE_DIR=/home/stack/stack/status
DEST=/home/stack/stack
SUBUNIT_OUTPUT=/home/stack/stack/devstack.subunit
LOGFILE=stack.sh.log
SCREEN_LOGDIR=/opt/stack/data/log
LOG_COLOR=False
#OFFLINE=True
RECLONE=yes
MULTI_HOST=1

disable_service swift
disable_service cinder
disable_service n-net
disable_service q-vpn
disable_service q-agt
enable_service q-svc
enable_service q-dhcp
enable_service q-meta
enable_service tempest
enable_service n-novnc
enable_service n-cauth

HOST_IP=<CONTROLLER_NODE_IP>
SERVICE_HOST=$HOST_IP

NEUTRON_CREATE_INITIAL_NETWORKS=False
Q_PLUGIN=ml2
Q_ML2_TENANT_NETWORK_TYPE=vxlan

ENABLE_TENANT_TUNNELS=True

VNCSERVER_PROXYCLIENT_ADDRESS=<CONTROLLER_NODE_IP>
VNCSERVER_LISTEN=0.0.0.0

FLOATING_RANGE=<NETWORK_SUBNET/24>
PUBLIC_NETWORK_GATEWAY=<GATEWAY_IP>

#Q_HOST=$SERVICE_HOST
MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
GLANCE_HOSTPORT=$SERVICE_HOST:9292
KEYSTONE_AUTH_HOST=$SERVICE_HOST
KEYSTONE_SERVICE_HOST=$SERVICE_HOST

DEFAULT_VOLUME_GROUP_NAME=stack-volumes-default


MYSQL_PASSWORD=<PASSWORD>
RABBIT_PASSWORD=<PASSWORD>
SERVICE_TOKEN=S<PASSWORD>
SERVICE_PASSWORD=<PASSWORD>
ADMIN_PASSWORD=<PASSWORD>

enable_plugin networking-odl https://github.com/openstack/networking-odl 
ODL_MGR_IP=<ODL_SERVER_IP>
ODL_PORT=8080
ODL_BOOT_WAIT=123
ODL_L3GW_MAC=<MAX_ADDRESS>
ODL_OVS_MANAGERS=<ODL_SERVER_IP>

# If using ODL outside devstack-control, replace ODL_MODE
ODL_MODE=externalodl
ODL_PROVIDER_MAPPINGS=br-ex:eth2

# Disable q-l3 and uncomment the lines below if ODL is being configured to perform l3fwd
# For more info:  https://github.com/openstack/networking-odl/blob/master/devstack/README.rst
# enable_service q-l3
disable_service q-l3
Q_L3_ENABLED=True
Q_ML2_PLUGIN_FLAT_TYPE_OPTIONS='flat_networks=\*'
ODL_L3=True
PUBLIC_INTERFACE=eth2
[[post-config|$NEUTRON_CONF]]
[DEFAULT]
service_plugins = networking_odl.l3.l3_odl.OpenDaylightL3RouterPlugin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]
[agent]
minimize_polling=True
[[post-config|$NOVA_CONF]]
[DEFAULT]
cpu_allocation_ratio = 16.0
ram_allocation_ratio = 4.0
disk_allocation_ratio = 1.0

Kind Regards, Rahul

C:\fakepath\OpenStack file.JPG

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-03-17 04:45:19 -0500

Vinoth gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2017-02-20 14:55:56 -0500

Seen: 701 times

Last updated: Mar 17 '17