ceilometer gnocchi deployment with kolla: using stable/newton all configs changed, mongo db still trying to connect wsgi.app.log and gateway timeouts for meter-list.

asked 2017-02-17 08:25:28 -0500

wallner_ryan gravatar image

Configured kolla to use gnocchi backend for ceilometer for the kolla 3.0.2 stable/newton branch.

ceilometer_database_type: "gnocchi"
gnocchi_backend_storage: "{{ 'ceph' if enable_ceph|bool else 'file' }}"

(ceph is up and running and gnocchi pool created no problem)

Ceilometer configuration is below

[DEFAULT]
debug = False
log_dir = /var/log/kolla/ceilometer
transport_url = rabbit://openstack:hidden@192.168.1.124:5672,openstack:hidden@192.168.1.129:5672,openstack:hidden@192.168.1.127:5672
meter_dispatchers = gnocchi
event_dispatchers = gnocchi

[api]
port = 8777
host = 192.168.1.124

[collector]

[database]

[keystone_authtoken]
memcached_servers = 192.168.1.254:11211
auth_uri = http://192.168.1.254:5000
project_domain_name = Default
project_name = service
user_domain_name = Default
username = ceilometer
password = hidden
auth_url = http://192.168.1.254:35357
auth_type = password

[notification]
store_events = true

[service_credentials]
auth_url = http://192.168.1.254:5000/v3
region_name = RegionOne
password = hidden
username = ceilometer
project_name = service
project_domain_id = default
user_domain_id = default
auth_type = password

[dispatcher_gnocchi]
filter_service_activity = False
url = http://192.168.1.254:8041
archive_policy = low

Yet, in this log cat /var/lib/docker/volumes/kolla_logs/_data/ceilometer/app.wsgi.log

I see

2017-02-17 14:19:16.214 20 ERROR ceilometer.storage.mongo.utils [-] Unable to reconnect to the primary mongodb after 10 retries. Giving up.
2017-02-17 14:19:40.765 16 WARNING ceilometer.storage.mongo.utils [-] Unable to reconnect to the primary mongodb: localhost:27017: [Errno 111] Connection refused. Trying again in 10 seconds.
2017-02-17 14:19:44.054 19 WARNING ceilometer.storage.mongo.utils [-] Unable to reconnect to the primary mongodb: localhost:27017: [Errno 111] Connection refused. Trying again in 10 seconds.
2017-02-17 14:19:56.302 20 WARNING ceilometer.storage.mongo.utils [-] Unable to reconnect to the primary mongodb: localhost:27017: [Errno 111] Connection refused. Trying again in 10 seconds.

I do not want to be using mongo, but rather gnocchi for backend, so not sure why this is happending unless kolla deployment still needs mongodb with gnocchi?

edit retag flag offensive close merge delete

Comments

@wallner_ryan are you sure Gnocchi is able to handle ceilometer events? I'm not 100% sure but maybe ceilometer is looking for mongodb to store the events (afaik, gnocchi only handles the metering part?). Try changing the events dispatcher to none, disabling store_events, etc.

gianpietro gravatar imagegianpietro ( 2017-02-17 14:40:20 -0500 )edit