Ask Your Question
0

Modular Layer 2 (ml2) Flat Type configuration options as flat_networks = * revert back to flat_networks = public while stacking in devstack

asked 2017-02-17 01:30:31 -0500

rahuly gravatar image

updated 2017-02-17 01:31:11 -0500

Hi,

I am using Devstack newton version with CentOS 7 LTS. I wanted the Modular Layer 2 (ml2) Flat Type configuration options as flat_networks = * . (ListOpt) List of physical_network names with which flat networks can be created. I have modified from flat_networks = public to Use * to allow flat networks with arbitrary physical_network names.

But when I stack back it has revert back to public. where can I do this modification to make the permanent.

Any solution please?

Kind Regards, Rahulan

edit retag flag offensive close merge delete

Comments

Not sure what you mean with "stack back". To create a a devstack with custom config, you can define settings in the local.conf file, usually at the end:

[[post-config|/$Q_PLUGIN_CONF_FILE]]
[ml2]
flat_networks = *
Bernd Bausch gravatar imageBernd Bausch ( 2017-02-17 04:05:54 -0500 )edit

Hi Brend, Thank you and I have tried the option but not working.

Kind Regards, Rahul

rahuly gravatar imagerahuly ( 2017-02-17 06:11:56 -0500 )edit

1 answer

Sort by ┬╗ oldest newest most voted
1

answered 2017-02-17 06:13:53 -0500

rahuly gravatar image

I have found the solution and I have added below command on my local.conf file.

Q_ML2_PLUGIN_FLAT_TYPE_OPTIONS='flat_networks=*'

if you don't put the above command the default come as public newton version devstack.

Kind Regards, Rahulan

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-02-17 01:30:31 -0500

Seen: 19 times

Last updated: Feb 17