Ask Your Question
0

ceilometer and gnocchi: no resources or metrics

asked 2017-02-16 22:08:27 -0600

Hi, I have a Newton manual setup in Ubuntu servers. I was using ceilometer with mongoDB backend, now I'm moving to Gnocchi and can't get it to work. This is what I got so far:

  1. Installed and configured Gnocchi with file storage DB, mysql indexer and keystone authentication.
  2. Configured gnocchi user, admin role and endpoints.
  3. Configured gnocchi as meter_dispatcher (no events) in ceilometer, and "gnocchi://" publisher in the pipeline (both controller and compute nodes); defined archive_policy as medium.
  4. Ran gnocchi-upgrade and initiated gnocchi api and metricd services successfully.
  5. Ran ceilometer-upgrade skipping both metering and event DBs / reloaded ceilometer services.

In ceilometer notification logs, I see some data being transformed:

2017-02-16 22:49:03.111 2773 DEBUG ceilometer.transformer.conversions [-] handling sample <name: disk.device.read.bytes, volume: 20182016, resource_id: d4e33a65-ff76-43ab-8423-12d1a07fd6e2-vda, timestamp: 2017-02-17T03:49:03.088084> handle_sample /usr/lib/python2.7/dist-packages/ceilometer/transformer/conversions.py:184
2017-02-16 22:49:03.113 2773 DEBUG ceilometer.transformer.conversions [-] converted to: <name: disk.device.read.bytes.rate, volume: 0.0, resource_id: d4e33a65-ff76-43ab-8423-12d1a07fd6e2-vda, timestamp: 2017-02-17T03:49:03.088084> handle_sample /usr/lib/python2.7/dist-packages/ceilometer/transformer/conversions.py:212

I have the resource types populated:

os@controller:~$ gnocchi resource-type list
+----------------------------+-------------------------------------------------------------------------------------+
| name                       | attributes                                                                          |
+----------------------------+-------------------------------------------------------------------------------------+
| ceph_account               |                                                                                     |
| generic                    |                                                                                     |
| host                       | - host_name: min_length: 0 , max_length: 255 , type: string , required: True        |
| host_disk                  | - host_name: min_length: 0 , max_length: 255 , type: string , required: True        |
|                            | - device_name: min_length: 0 , max_length: 255 , type: string , required: False     |
...

I see the archive policies in the metric list:

os@controller:~$ gnocchi metric list
+--------------------------------------+---------------------+------+------+-------------+
| id                                   | archive_policy/name | name | unit | resource_id |
+--------------------------------------+---------------------+------+------+-------------+
| 4e6dfdf5-fd01-4202-b50c-4a5f1ba62595 | high                | None | None | None        |
| 849c2e24-680b-48fd-b423-e862eac7c0e0 | low                 | None | None | None        |
| b1f8ac47-7091-446f-a22e-4a0b92460a86 | high                | None | None | None        |
+--------------------------------------+---------------------+------+------+-------------+

But no instance metrics or resources at all, there should be at least the default ones from ceilometer right? I have some machines running but resource list shows empty.

Any hint will be appreciated.

Thanks.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2017-03-24 07:45:06 -0600

yprokule gravatar image

As @xtrilla already pointed - publisher has to be notifier in pipeline.yaml and ceilometer itself will take care of sending data to gnocchi.

Worth checking ceilometer/collector.log - if ceilometer has problems communicating with gnocchi, those would be here.

edit flag offensive delete link more

Comments

Hello @yprokule I installed ceilometer and gnocchi via devstack and did this to enable logs LOGFILE=$DEST/logs/stack.sh.log VERBOSE=True LOG_COLOR=False SCREEN_LOGDIR=$DEST/logs/screen but I could not find any logs related to gnocchi and ceilometer can help me how to enable log files ?

viinay gravatar imageviinay ( 2017-08-02 05:19:06 -0600 )edit
0

answered 2017-02-17 07:57:25 -0600

xtrilla gravatar image

I'm not really sure right now -been a while since I configured a similar setup- but it is my understanding that the agents in the compute nodes need to send the data to ceilometer and then ceilometer will transform the data and send it to gnocchi.

Seeing the information you posted looks like maybe the issue is in ceilometer and it is not posting the events to gnnochi.

What I don't really get about your question is this:

Configured gnocchi as meter_dispatcher (no events) in ceilometer, and "gnocchi://" publisher in the pipeline (both controller and compute nodes); defined archive_policy as medium.

I mean, as far as I know you don't need to add gnocchi to the compute nodes, as they will report to ceilometer and ceilometer will transform and store in gnocchi.

I don't know if this will help you, but maybe it will point you in the right direction :/

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-02-16 22:08:27 -0600

Seen: 1,138 times

Last updated: Mar 24