Ask Your Question
0

single node kolla deployment failed while starting heka container: internal server error?

asked 2017-02-16 06:50:43 -0500

harish23r gravatar image

updated 2017-02-24 02:52:45 -0500

I'm trying to deploy a single node installation of kolla, which I will later be extending to 2 hosts. All the steps work until the "kolla-ansible deploy" command. Tried with Docker version 1.12 as well as version 1.13.
I've build all the container images using kolla-build command and pushed the images in the local docker registry running at port 4000. I configured by giving the correct values globals.yml file for the repository.

When I give kolla-ansible deploy, the deployment stops while starting heka container with the following error:
TASK: [common | starting heka container] *********** failed: [localhost] => {"changed": true, "failed": true} msg: APIError(HTTPError(u'500 Server Error: Internal Server Error for url: http+docker://localunixsocket/v1.25/containers/create?name=heka',),)

FATAL: all hosts have failed -- aborting

localhost : 0k=28 changed=0 unreachable=0 failed=1

I'm not sure if this is a config mistake with openstack kolla or with docker. I gave docker_insecure_registry to true in the globals.yml file. Is there some configuration I'm missing? Any place where I can check with detailed steps for deploying kolla?

Please help me, this is required for my capstone project.!

EDIT: While using Kolla-build, I build only specific images and pushed it to the registry, only horizon, glance, nova, neutron, keystone. Will that be a problem?

edit retag flag offensive close merge delete

Comments

Is configured docker daemon to use the insecure registry? Check with:

[root@controller kolla-ansible]# cat /etc/systemd/system/docker.service.d/kolla.conf 
[Service]
[Service]
ExecStart=
ExecStart=/usr/bin/dockerd --insecure-registry 192.168.100.215:4000
MountFlags=shared
Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-02-17 03:44:47 -0500 )edit

Are you able to manually pull heka image?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-02-17 03:45:38 -0500 )edit

I do not have a kolla.conf file in the system. But the docker has started on start up.

harish23r gravatar imageharish23r ( 2017-02-23 01:52:14 -0500 )edit

I have configured the DOCKER_OPTS="--insecure-registry ID_ADDRESS:4000" option in my /etc/default/docker file in my Ubuntu 16.04. Still the issue persists . @Eduardo Gonzalez

harish23r gravatar imageharish23r ( 2017-02-24 02:44:52 -0500 )edit

While using Kolla-build, I build only specific images and pushed it to the registry, only horizon, glance, nova, neutron, keystone. Will that be a problem?

harish23r gravatar imageharish23r ( 2017-02-24 02:54:08 -0500 )edit

2 answers

Sort by ┬╗ oldest newest most voted
0

answered 2017-02-27 04:29:57 -0500

9lives gravatar image

We also found similar issue in latest kolla build ie. ocata.

The error message is

    "msg": "'Traceback (most recent call last):\\n  File \"/tmp/ansible_GVV84n/ansible_module_kolla_docker.py\", line 742, in main\\n    result = bool(getattr(dw, module.params.get(\\'action\\'))())\\n  File \"/tmp/ansible_GVV84n/ansible_module_kolla_docker.py\", line 567, in start_container\\n    self.create_container()\\n  File \"/tmp/ansible_GVV84n/ansible_module_kolla_docker.py\", line 555, in create_container\\n    self.dc.create_container(**options)\\n  File \"/usr/local/lib/python2.7/dist-packages/docker/api/container.py\", line 119, in create_container\\n    return self.create_container_from_config(config, name)\\n  File \"/usr/local/lib/python2.7/dist-packages/docker/api/container.py\", line 130, in create_container_from_config\\n    return self._result(res, True)\\n  File \"/usr/local/lib/python2.7/dist-packages/docker/client.py\", line 150, in _result\\n    self._raise_for_status(response)\\n  File \"/usr/local/lib/python2.7/dist-packages/docker/client.py\", line 146, in _raise_for_status\\n    raise errors.APIError(e, response, explanation=explanation)\\nAPIError: 500 Server Error: Internal Server Error (\"{\"message\":\"maximum retry count cannot be used with restart policy \\'unless-stopped\\'\"}\")\\n'"
}

does anyone know what is the root cause of it?

Thanks!

edit flag offensive delete link more

Comments

Thats an issue with docker 1.13, better downgrade to 1.12.6. Anyway that issue was fixed in ocata, are you sure are using ocata code? Ocata does not have heka and that error was early fixed much more before relase ocata

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-02-27 04:50:16 -0500 )edit
Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-02-27 04:51:43 -0500 )edit

it should be in the ocata branch cos' run the git branch it shows like this

  master
* stable/ocata

but when i rebuild the kolla* binary error occured

ImportError: No module named pbr_json
9lives gravatar image9lives ( 2017-02-27 05:46:31 -0500 )edit

Ocata is released, if want to use stable version install it from pip, if don't want to use version in pip, execute the commands from tools directory: ./tools/kolla-ansible instead of kolla-ansible:

pip install kolla-ansible
Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-02-27 05:56:18 -0500 )edit

I tried to restart using the python virtualenv to install the ocata version kolla when doing aio deployment, error occured like this is there any known bug out there?

 AttributeError: 'module' object has no attribute 'connection'\n"
9lives gravatar image9lives ( 2017-02-28 05:18:03 -0500 )edit
0

answered 2017-02-22 01:09:41 -0500

have u solved your problem? I have the same question but I do not know how to fix it

edit flag offensive delete link more

Comments

Have you checked my comments in the question? If so, can you check if that is the issue or not to dig more into the issue. The errors is likely the registry issue I comment.

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-02-22 17:19:23 -0500 )edit

I use ubuntu instead of Centos, I believed it is not about the registry issue. I just follow the step in https://docs.openstack.org/developer/kolla/mitaka/quickstart.html (https://docs.openstack.org/developer/...), and I got APIError, this page said that it relates to the mountflag, but I have already done that before.

qunnn41 gravatar imagequnnn41 ( 2017-02-22 19:24:37 -0500 )edit

Steps for ubuntu are missing, but need to add in /etc/default/docker

DOCKER_OPTS="--insecure-registry ID_ADDRESS:4000"

And then restart docker service. Also try to manually pull an image from registry, or with kolla-ansible pull -i inventory-file If that don't fail, is another issue.

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-02-23 05:08:03 -0500 )edit

I have configured the DOCKER_OPTS="--insecure-registry ID_ADDRESS:4000" option in my /etc/default/docker file in my Ubuntu 16.04. Still the issue persists .

harish23r gravatar imageharish23r ( 2017-02-24 02:44:38 -0500 )edit

Is theera any other option I need to check? Output for kolla-ansible pull -i inventory_file is below: Pulling Docker images : ansible-playbook -i inventory-file -e @/etc/kolla/globals.yml -e @/etc/kolla/passwords.yml -e CONFIG_DIR=/etc/kolla -e action=pull /usr/local/share/kolla/ansible/site.yml

harish23r gravatar imageharish23r ( 2017-02-24 02:46:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2017-02-16 06:09:46 -0500

Seen: 1,042 times

Last updated: Feb 27 '17