Heat Scaling_policy alarm_url is null

asked 2017-02-14 14:15:01 -0500

JackLin gravatar image

Hi!
I am now using mitaka and installed manually.
After installed Heat, I wanted to try auto-scaling function but faced some problems.
Here is my yaml file.

And when I create the stack, it failed right after scaling_policy creating complete and OS::Ceilometer::alarm initiating

After researching for a while, I found that it might caused by the scaling_policy didn't create the alarm_url,
and the scaling_policy resource's alarm_url is null
(or what I guessed is wrong)

My openstack-heat-api-cfn.service works well, and I have create the endpoint of it.

Is there anyone know how can I fixed it or why it happened?
Thanks a lot!

edit retag flag offensive close merge delete

Comments

The heat-engine log probably has more details. It might be easier to just switch to using signal_url instead - that goes through the native API instead of the cfn API.

zaneb gravatar imagezaneb ( 2017-02-15 08:24:30 -0500 )edit