Devstack ML2 not be able to communicate with external ODL flat network in newton version?

asked 2017-02-14 07:19:54 -0500

rahuly gravatar image

updated 2017-02-14 12:15:40 -0500

rbowen gravatar image

Hi, I am using three server as one Controle node, second Compute node and third for Opendaylight (odl-ovsdb-openstack) ovs management. It is stacking successfully, but not able to create below command for network creation:-

openstack create ctrl-external --router:external=True --provider:physical_network public --provider:network_type flat --provider:physical_network physnet1

error was thrown as below:- neutron CLI is deprecated and will be removed in the future. Use openstack CLI instead. Invalid input for operation: physical_network 'physnet1' unknown for flat provider network. Neutron server returns request_ids: ['req-4fcb4d8d-9372-4c08-b3d3-ee9a50d3f836']

Please see my local.conf

DATA_DIR=/home/stack/stack/data
SERVICE_DIR=/home/stack/stack/status
DEST=/home/stack/stack
SUBUNIT_OUTPUT=/home/stack/stack/devstack.subunit
LOGFILE=stack.sh.log
SCREEN_LOGDIR=/opt/stack/data/log
LOG_COLOR=False
#OFFLINE=True
RECLONE=yes
MULTI_HOST=1

disable_service swift
disable_service cinder
disable_service n-net
disable_service q-vpn
enable_service q-svc
enable_service q-dhcp
enable_service q-meta
enable_service tempest
enable_service n-novnc
enable_service n-cauth


HOST_IP=<CONTROLLER_NODE_IP>
SERVICE_HOST=$HOST_IP

NEUTRON_CREATE_INITIAL_NETWORKS=False
Q_PLUGIN=ml2
Q_ML2_TENANT_NETWORK_TYPE=vxlan

ENABLE_TENANT_TUNNELS=True

VNCSERVER_PROXYCLIENT_ADDRESS=<CONTROLLER_NODE_IP>
VNCSERVER_LISTEN=0.0.0.0

FLOATING_RANGE=<NETWORK_SUBNET/24>
PUBLIC_NETWORK_GATEWAY=<GATEWAY_IP>

#Q_HOST=$SERVICE_HOST
MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
GLANCE_HOSTPORT=$SERVICE_HOST:9292
KEYSTONE_AUTH_HOST=$SERVICE_HOST
KEYSTONE_SERVICE_HOST=$SERVICE_HOST

DEFAULT_VOLUME_GROUP_NAME=stack-volumes-default


MYSQL_PASSWORD=<PASSWORD>
RABBIT_PASSWORD=<PASSWORD>
SERVICE_TOKEN=S<PASSWORD>
SERVICE_PASSWORD=<PASSWORD>
ADMIN_PASSWORD=<PASSWORD>

enable_plugin networking-odl https://github.com/openstack/networking-odl 
ODL_MGR_IP=<ODL_SERVER_IP>
ODL_PORT=8080
ODL_BOOT_WAIT=123
ODL_L3GW_MAC=<MAX_ADDRESS>
ODL_OVS_MANAGERS=<ODL_SERVER_IP>

# If using ODL outside devstack-control, replace ODL_MODE
ODL_MODE=externalodl
ODL_PROVIDER_MAPPINGS=br-ex:eth2

# Disable q-l3 and uncomment the lines below if ODL is being configured to perform l3fwd
# For more info:  https://github.com/openstack/networking-odl/blob/master/devstack/README.rst
# enable_service q-l3
disable_service q-l3
Q_L3_ENABLED=True
ODL_L3=True
PUBLIC_INTERFACE=eth2
[[post-config|$NEUTRON_CONF]]
[DEFAULT]
service_plugins = networking_odl.l3.l3_odl.OpenDaylightL3RouterPlugin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]
[agent]
minimize_polling=True
[[post-config|$NOVA_CONF]]
[DEFAULT]
cpu_allocation_ratio = 16.0
ram_allocation_ratio = 4.0
disk_allocation_ratio = 1.0

Is there any one I can contact , thank you.

Kind Regards, Rahul

edit retag flag offensive close merge delete

Comments

I don't know about ODL, but you must have a config parameter that maps the external network name (physnet1 in your case) to an external access. In the case of the Openvswitch mech driver, it's bridge_mappings.

Bernd Bausch gravatar imageBernd Bausch ( 2017-02-14 20:19:58 -0500 )edit

I have tried this but no luck Thsnks

rahuly gravatar imagerahuly ( 2017-02-16 04:12:27 -0500 )edit