Ask Your Question
0

Even though I have configured my public ip in my instance still I am not able to ssh in it?

asked 2014-01-09 05:01:58 -0500

anonymous user

Anonymous

The nova show command is showing power state : 1, state : active and allocated public and private ips.

Still it is showing ssh no route to host error.

edit retag flag offensive close merge delete

Comments

1

Please check this site for suggestions on how to further debug the issue. As it is now, your question is too generic to get an answer.

smaffulli gravatar imagesmaffulli ( 2014-01-10 14:40:54 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-12-04 11:36:56 -0500

sputnik13 gravatar image

If this is your first time working with Openstack, a common problem is overlooking security groups. Security groups define what essentially ends up being firewall rules for your tenant. By default openstack creates tenants with very restrictive security groups, allow everything out but allow nothing in unless it's from VMs in the same tenant.

To allow ssh from an external (public) IP you would need to add an ingress rule to allow SSH traffic.

Here's a graphical step by step

https://www.mirantis.com/openstack-po...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-09 05:01:58 -0500

Seen: 127 times

Last updated: Dec 04 '14