Ask Your Question
0

AttributeError: 'module' object has no attribute 'URIOpt'

asked 2017-02-11 08:47:45 -0600

hologramicSurround gravatar image

Hello

I am running ./stack.sh and it stops due to error "AttributeError: 'module' object has no attribute 'URIOpt'". Any help to fix the issue would be much appreciated.

The last lines of the terminal after error: 17-02-10 23:42:13.682 |     public_endpoint = cfg.URIOpt(br> 2017-02-10 23:42:13.683 | AttributeError: 'module' object has no attribute 'URIOpt'
2017-02-10 23:42:13.920 | + lib/keystone:init_keystone:1             :   exit_trap
2017-02-10 23:42:13.937 | + ./stack.sh:exit_trap:474                 :   local r=1
2017-02-10 23:42:13.964 | ++ ./stack.sh:exit_trap:475                 :   jobs -p
2017-02-10 23:42:13.975 | + ./stack.sh:exit_trap:475                 :   jobs=
2017-02-10 23:42:13.998 | + ./stack.sh:exit_trap:478                 :   [[ -n '' ]]
2017-02-10 23:42:14.040 | + ./stack.sh:exit_trap:484                 :   kill_spinner
2017-02-10 23:42:14.068 | + ./stack.sh:kill_spinner:370              :   '[' '!' -z '' ']'
2017-02-10 23:42:14.100 | + ./stack.sh:exit_trap:486                 :   [[ 1 -ne 0 ]]
2017-02-10 23:42:14.117 | + ./stack.sh:exit_trap:487                 :   echo 'Error on exit'
2017-02-10 23:42:14.117 | Error on exit
2017-02-10 23:42:14.137 | + ./stack.sh:exit_trap:488                 :   generate-subunit 1486766190 3944 fail
2017-02-10 23:42:16.054 | + ./stack.sh:exit_trap:489                 :   [[ -z /opt/stack/logs ]]
2017-02-10 23:42:16.060 | + ./stack.sh:exit_trap:492                 :   /home/stack/devstack/tools/worlddump.py
-d /opt/stack/logs
2017-02-10 23:42:12017-02-10 23:42:13.682 |     public_endpoint = cfg.URIOpt(
2017-02-10 23:42:13.683 | AttributeError: 'module' object has no attribute 'URIOpt'
2017-02-10 23:42:13.920 | + lib/keystone:init_keystone:1             :   exit_trap
2017-02-10 23:42:13.937 | + ./stack.sh:exit_trap:474                 :   local r=1
2017-02-10 23:42:13.964 | ++ ./stack.sh:exit_trap:475                 :   jobs -p
2017-02-10 23:42:13.975 | + ./stack.sh:exit_trap:475                 :   jobs=
2017-02-10 23:42:13.998 | + ./stack.sh:exit_trap:478                 :   [[ -n '' ]]
2017-02-10 23:42:14.040 | + ./stack.sh:exit_trap:484                 :   kill_spinner
2017-02-10 23:42:14.068 | + ./stack.sh:kill_spinner:370              :   '[' '!' -z '' ']'
2017-02-10 23:42:14.100 | + ./stack.sh:exit_trap:486                 :   [[ 1 -ne 0 ]]
2017-02-10 23:42:14.117 | + ./stack.sh:exit_trap:487                 :   echo 'Error on exit'
2017-02-10 23:42:14.117 | Error on exit
2017-02-10 23:42:14.137 | + ./stack.sh:exit_trap:488                 :   generate-subunit 1486766190 3944 fail
2017-02-10 23:42:16.054 | + ./stack.sh:exit_trap:489                 :   [[ -z /opt/stack/logs ]]
2017-02-10 23:42:16.060 | + ./stack.sh:exit_trap:492                 :   /home/stack/devstack/tools/worlddump.py
-d /opt/stack/logs
2017-02-10 23:42:1

edit retag flag offensive close merge delete

Comments

There is probably an earlier error that causes this problem. The stack.sh log file is likely to have more information.

Bernd Bausch gravatar imageBernd Bausch ( 2017-02-11 09:14:24 -0600 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2017-03-22 11:39:23 -0600

sbiswas7 gravatar image

updated 2017-03-22 11:40:15 -0600

You probably have an older version of oslo_config that does not URIOpt. You could verify this quickly by getting into your python CLI and running:

">>> from oslo_config import cfg"

">>> dir(cfg)"

And see if URIOpt is present as an attribute there. If not, try updating oslo_config explicitly via pip.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-02-11 08:47:45 -0600

Seen: 527 times

Last updated: Mar 22 '17