Ask Your Question
0

Opendaylight controller not detecting openvswitch on Openstack controller

asked 2017-02-10 09:44:03 -0500

Suresh Nagaraj gravatar image

updated 2017-02-10 10:32:19 -0500

rbowen gravatar image

Hi All,

I need your help in openvswitch being controlled by opendaylight controller via management interfaces. Below is the topology.

[ODL Controller]10.132.232.4---------[switch]---------10.132.232.9[Openstack controller]

Openstack Controller: Below is my local.conf file. Iam using stable/newton branch for devstack installation on Ubuntu LTS 14.04 machine. After successful devstack installation Iam facing issues which are mentioned below.

1) After devstack installation when the below 2 commands are executed, I dont see the ODL controller[IP: 10.132.232.4] detecting the open vSwitch of the openstack controller[IP: 10.132.232.9].

sudo ovs-vsctl set-manager tcp:10.132.232.4:6640
sudo ovs-vsctl set-controller br-ex tcp:10.132.232.4:6653

The output of "sudo ovs-vsctl show" for manager and controller shows the is_connected=false value.

2) After devstack installation. I am creating a 3 instances and I am able to access the VM's through ssh. But once set-manager and set-controller are executed as mentioned above, I will be not be able to ssh to the instances. I get error "No route to host". Please help me out how can this issue be fixed and also let me know if any changes required in local.conf or system files.

Local.conf
##########

[[local|localrc]]
HOST_IP=10.132.232.9
SERVICE_HOST=10.132.232.9
MYSQL_HOST=10.132.232.9
RABBIT_HOST=10.132.232.9
GLANCE_HOSTPORT=10.132.232.9:9292
ADMIN_PASSWORD=supersecret
DATABASE_PASSWORD=iheartdatabases
RABBIT_PASSWORD=flopsymopsy
SERVICE_PASSWORD=iheartksl

#RECLONE=yes

disable_service n-net
#Enable heat services
enable_service h-eng h-api h-api-cfn h-api-cw
#Enable heat plugin
enable_plugin heat https://git.openstack.org/openstack/heat

IMAGE_URL_SITE="https://dl.fedoraproject.org"
IMAGE_URL_PATH="/pub/archive/fedora/linux/releases/21/Cloud/Images/x86_64/"
IMAGE_URL_FILE="Fedora-Cloud-Base-20141203-21.x86_64.qcow2"
IMAGE_URLS+=","$IMAGE_URL_SITE$IMAGE_URL_PATH$IMAGE_URL_FILE

enable_service q-svc q-agt q-dhcp q-l3 q-meta neutron

## Neutron options
Q_USE_SECGROUP=True
FLOATING_RANGE="10.132.232.0/24"
IPV4_ADDRS_SAFE_TO_USE="172.0.0.0/22"
Q_FLOATING_ALLOCATION_POOL=start=10.132.232.250,end=10.132.232.254
PUBLIC_NETWORK_GATEWAY="10.132.232.1"
PUBLIC_INTERFACE=eth2

# Open vSwitch provider networking configuration
Q_USE_PROVIDERNET_FOR_PUBLIC=True
OVS_PHYSICAL_BRIDGE=br-ex
PUBLIC_BRIDGE=br-ex
OVS_BRIDGE_MAPPINGS=public:br-ex
Q_PLUGIN=ml2

Thanks -Suresh

edit retag flag offensive close merge delete

Comments

In you devstack local.conf, I don't see any odl related configuration. odl is not the default network service.

Karthik Prasad gravatar imageKarthik Prasad ( 2017-02-28 05:56:28 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-10-03 16:38:35 -0500

Samone gravatar image

I had exctly the same problem after setting odl controller as a ovswitch manager, I could not create instances as an error message is generated. is here anyone who could help on how to get this issue fixed??

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-02-10 09:44:03 -0500

Seen: 211 times

Last updated: Feb 10 '17