SRIOV Agent on Newton failed to talk with rabbitmq due to tlsv1

asked 2017-02-08 21:51:48 -0500

chz8494 gravatar image

I tried to enable SRIOV on my openstack environment, the SRIOV port creation part is fine, but nova scheduler fails as "there's no valid hosts available". After further digging, I found that the communication between rabbitmq and sriov agent is the root cause. SRIOV agent I installed via repo "apt-get install neutron-plugin-sriov-agent", and it uses TLSv1 to talk with rabbitmq which only accepts TLSv1.1 or higher. I can't force rabbitmq to trust TLSv1 as it's hacked and not safe anymore. So is there a way to make SRIOV agent use TLSv1.1 instead?

edit retag flag offensive close merge delete