Ask Your Question
0

Could not connect to gerrit

asked 2017-02-03 05:29:02 -0500

EkuIitr gravatar image

ekansh@ekansh-HP-Pavilion-Notebook:~/core$ git review -s

Could not connect to gerrit.

Enter your gerrit username: ekuiitr

Trying again with ssh://ekuiitr@logerrit:29418/core <traceback object="" at="" 0x7fdfcd3ce488="">

We don't know where your gerrit is. Please manually create a remote named "logerrit" and try again.

Traceback (most recent call last):

File "/usr/bin/git-review", line 1196, in <module> main()

File "/usr/bin/git-review", line 1110, in main config['hostname'], config['port'], config['project'])

File "/usr/bin/git-review", line 489, in check_remote add_remote(hostname, port, project, remote)

File "/usr/bin/git-review", line 344, in add_remote raise Exception("Could not connect to gerrit at %s" % remote_url)

Exception: Could not connect to gerrit at ssh://ekuiitr@logerrit:29418/core

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-03-10 16:26:12 -0500

karthikprabhu gravatar image

Yes, sometimes the gerrit struggles to find the remote. You can get it to work by creating a git remote manually in your local git folder and then perform git review -s. In my case, it is cinder. It should work after that

git remote add gerrit ssh://<gerrit-username>@review.openstack.org:29418/openstack/cinder.git

Hope this helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-02-03 05:29:02 -0500

Seen: 540 times

Last updated: Mar 10 '17