Ask Your Question
0

Nova-compute not showing on nova service-list(controller)

asked 2017-02-02 04:43:07 -0500

prakashs gravatar image

updated 2017-02-02 05:04:51 -0500

OS: Ubuntu 16 Openstack: Newton

Nova-compute not showing on nova service-list(controller)

I'm stuck on this step and let me know how to troubleshoot and fix it.

root@controller:~# openstack compute service list
+----+------------------+------------+----------+---------+-------+----------------------------+
| ID | Binary           | Host       | Zone     | Status  | State | Updated At                 |
+----+------------------+------------+----------+---------+-------+----------------------------+
|  1 | nova-consoleauth | controller | internal | enabled | up    | 2017-02-02T10:41:59.000000 |
|  5 | nova-scheduler   | controller | internal | enabled | up    | 2017-02-02T10:41:59.000000 |
|  6 | nova-conductor   | controller | internal | enabled | up    | 2017-02-02T10:42:04.000000 |
+----+------------------+------------+----------+---------+-------+----------------------------+
root@controller:~#
edit retag flag offensive close merge delete

Comments

Check rabbitmq connection in nova-compute host telnet, config options, errors in nova-compute.log

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-02-02 05:05:40 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-02-02 05:07:56 -0500

updated 2017-02-02 05:09:17 -0500

If you are referring to the steps in the install guides: Check if the nova-compute process is running on the compute node. If not, you need to find out why it doesn't run. The nova-compute.log file will help.

If it does run, it's probably unable to tell nova-api that it is running. Most probably a message queue problem. Again, look for ERRORs or WARNINGs in the same log file. Typical scenarios: No time synchronization between controller and compute node, or wrong message queue credentials configured, or no network connection (e.g. firewall).

edit flag offensive delete link more

Comments

This is not an answer, its a suggestion ?

Bipin gravatar imageBipin ( 2017-02-02 05:27:19 -0500 )edit

The question is "let me know how to troubleshoot and fix it". What I wrote is an answer to this question.

Bernd Bausch gravatar imageBernd Bausch ( 2017-02-02 05:41:35 -0500 )edit

nova-compute process is running in compute node, time sync is accurate, 5672 is LISTENING in controller, 5672 port is working from compute node tested with telnet. let me know how to troubleshoot messaging. Errors from nova-compute log 7249 ERROR nova.virt.driver 8088 ERROR oslo.messaging._drivers.

prakashs gravatar imageprakashs ( 2017-02-02 10:31:07 -0500 )edit

nreachable: [Errno 111] ECONNREFUSED. Trying again in 2 seconds. Client port: None 8126 ERROR oslo_service.periodic_task

prakashs gravatar imageprakashs ( 2017-02-02 10:31:52 -0500 )edit

So it's a connectivity problem. You say the MQ server is reachable from the compute node. I would check the MQ config in nova.conf on the compute node. If all else fails, trace packets with tcpdump.

Bernd Bausch gravatar imageBernd Bausch ( 2017-02-02 18:28:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-02-02 04:43:07 -0500

Seen: 1,021 times

Last updated: Feb 02 '17