Ask Your Question
0

'ExtensionManager' object does not support item assignment

asked 2014-01-08 09:45:44 -0500

Atti gravatar image

updated 2014-01-22 15:12:38 -0500

Evgeny gravatar image

Hi guys, I installed Neutron on the Ubuntu according to recommendations in the http://docs.openstack.org/trunk/install-guide/install/apt/content/install-neutron.install-plug-in.html (docs). But when I started the service I got:

2014-01-08 17:20:49.232 4617 ERROR neutron.common.legacy [-] Skipping unknown group key: firewall_driver
2014-01-08 17:20:50.370 4617 WARNING neutron.api.extensions [-] Extension flavor not supported by any of loaded plugins
2014-01-08 17:20:50.371 4617 WARNING neutron.api.extensions [-] Extension lbaas_agent_scheduler not supported by any of loaded plugins
2014-01-08 17:20:50.386 4617 WARNING neutron.api.extensions [-] Extension service-type not supported by any of loaded plugins
2014-01-08 17:20:50.388 4617 WARNING neutron.api.extensions [-] Extension routed-service-insertion not supported by any of loaded plugins
2014-01-08 17:20:50.389 4617 WARNING neutron.api.extensions [-] Extension port-security not supported by any of loaded plugins
2014-01-08 17:20:50.391 4617 WARNING neutron.api.extensions [-] Extension security-group not supported by any of loaded plugins
2014-01-08 17:20:50.393 4617 WARNING neutron.api.extensions [-] Extension metering not supported by any of loaded plugins
2014-01-08 17:20:50.396 4617 WARNING neutron.api.extensions [-] Extension router-service-type not supported by any of loaded plugins
2014-01-08 17:20:50.408 4617 WARNING neutron.api.extensions [-] Extension vpnaas not supported by any of loaded plugins
2014-01-08 17:20:50.411 4617 WARNING neutron.api.extensions [-] Extension fwaas not supported by any of loaded plugins
2014-01-08 17:20:50.414 4617 WARNING neutron.api.extensions [-] Extension lbaas not supported by any of loaded plugins
2014-01-08 17:20:50.415 4617 WARNING neutron.api.extensions [-] Extension multi-provider not supported by any of loaded plugins

and commands in neutron-client return:

ExtensionManager' object does not support item assignment

What causes such a problem?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-04-04 03:06:23 -0500

hi,how to install the latest python-neutronclient from github?

edit flag offensive delete link more
0

answered 2014-01-09 15:13:35 -0500

craigtracey gravatar image

Hi Atti,

The problem here is that you are using the latest version of cliff (1.5.2). See this bug: https://bugs.launchpad.net/python-neutronclient/+bug/1165962

Ultimately cliff has changed in 1.5.2 and the python requirements called out by python-neutronclient only call for cliff>=1.4.1, hence you got the latest.

I also ran into this. I think you have a few options: 1) install the latest python-neutronclient from github 2) ensure that you are using cliff < 1.5.2. (The next latest is 1.4.5)

Are you installing via packages?

Hope this helps, Craig

edit flag offensive delete link more

Comments

how to install the latest python-neutronclient from github ,or it will change the config file?

anicething gravatar imageanicething ( 2014-04-04 03:32:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-08 09:45:44 -0500

Seen: 1,928 times

Last updated: Apr 04 '14