Ask Your Question
0

Neutron-server gives ERROR while integrating with OVN

asked 2017-02-01 05:55:18 -0600

pjb gravatar image

Following this link for deploying a multi-node set-up of OpenStack Newton(OVN).

Integration of OVN fails. Checked in Neutron LOG to find this :

ERROR networking_ovn.ovsdb.impl_idl_ovn [-] OVS database connection to OVN_Northbound failed with error: '{u'error': u'unknown database', u'details': u'get_schema request specifies unknown database OVN_Northbound', u'syntax': u'["OVN_Northbound"]'}'. Verify that the OVS and OVN services are available and that the 'ovn_nb_connection' and 'ovn_sb_connection' configuration options are correct.

Stuck in this for more than 1 week. Starting to hate my life. Please help. Before I tried installing in physical machines, followed the same guide and installed in VMs. Everything was working then.

Solutions I tried: 1) Completely fresh installing everything. 2) Rebuilding ovs 3) Check SB and NB configuration options are exactly correct.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-10-03 20:27:44 -0600

Neeseius gravatar image

updated 2017-10-03 20:38:48 -0600

The problem is the latest repo for openvswitch-ovn-common has a broken /usr/share/openvswitch/scripts/ovn-ctl script causing nb not to listen on 6641 and 6642

You'll need to pull down openvswitch-ovn-common from ocata and grab that script out of there.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-02-01 05:55:18 -0600

Seen: 122 times

Last updated: Oct 03 '17