Ask Your Question

Packstack installation always gives error of mariadb-server being obsolete and removed by mysql-community-server which is already installed

asked 2017-01-31 10:23:44 -0600

engritesh gravatar image

Hello, I am installing OpenStack mitaka (tried with Newton also) over Centos 7 using Packstack. It is a Single node installation. Have used following commands to install -

yum install -y centos-release-openstack-mitaka yum install -y openstack-packstack packstack --answer-file /root/answers.txt

But even after updating centos, reinstalling mysql many times, I am getting same error -

Copying Puppet modules and manifests                 [ DONE ]
Applying                        [ ERROR ]
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run:
Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install mariadb-server-galera' returned 1: Package 3:mariadb-server-10.1.18-3.el7.x86_64 is obsoleted by mysql-community-server-5.7.17-1.el7.x86_64 which is already installed
You will find full trace in log /var/tmp/packstack/20170131-212844-VEGrWK/manifests/

I have already removed mysql-community-server and tried it, installed mysql-community-server again and tried it, even uninstalled mysql-community-server and installed mariadb-server-galera (which inturn installed mysql-community-server only) but none of these worked.

Any clue/help would be appreciated.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2017-01-31 11:12:09 -0600

dbaxps gravatar image

updated 2017-01-31 11:19:28 -0600

Posting below is addressing multiple questions raising up at regarding packstack AIO or Multi Node RDO Newton installations on CentOS 7.2. Instructions bellow explain how to use RDO Newton trunk "current-passed-ci" for packstack installation.


edit flag offensive delete link more


Hi, Thanks for reply.. However, the "yum update" command started giving error in delorean-deps-newton.repo and delorean-newton.repo files after using the steps mentioned here.

I checked "ls -l /etc/yum.repos.d" and till there it was as mentioned in the link.

engritesh gravatar imageengritesh ( 2017-02-01 00:19:30 -0600 )edit

Please, post

1. ls -l /etc/yum.repos.d
2. Content of delorean repos
dbaxps gravatar imagedbaxps ( 2017-02-01 02:11:25 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-01-31 10:23:44 -0600

Seen: 956 times

Last updated: Jan 31 '17