Ask Your Question
0

network problem- physical network VLANs (two physical eth*)

asked 2017-01-22 00:16:07 -0500

hossam gravatar image

hello im trying two physical network cards with RDO allinone test environment. im successful with attaching the two network cards to openstack and can provide openstack VMS with ips from both network cards (br-ex&br-ex1) my problem is i can reach br-ex and br-ex1 ips from any vlan in network but when login ssh to rdo node and ping any vlan not (br-ex and br-ex1) i cant .

my configuration

br-ex   :-10.13.43.22  
br-ex1 :-10.13.44.22
br-ex GW :- 10.13.43.1 
br-ex1 GW :-10.13.44.1

[root@RDO network-scripts]# cat ifcfg-eth0
DEVICE=eth0
NAME=eth0
DEVICETYPE=ovs
TYPE=OVSPort
OVS_BRIDGE=br-ex
ONBOOT=yes
BOOTPROTO=none
------------------------------------------------------------------------------
[root@RDO network-scripts]# cat ifcfg-eth1
DEVICE=eth1
NAME=eth1
DEVICETYPE=ovs
TYPE=OVSPort
OVS_BRIDGE=br-ex1
ONBOOT=yes
BOOTPROTO=none
------------------------------------------------------------------------------
[root@RDO network-scripts]# cat ifcfg-br-ex
ONBOOT=yes
IPADDR=10.13.43.22
NETMASK=255.255.255.0
NETWORK=10.13.43.0
VLAN=yes
DEVICE=br-ex
NAME=br-ex
DEVICETYPE=ovs
OVSBOOTPROTO=static
TYPE=OVSBridge
------------------------------------------------------------------------------
[root@RDO network-scripts]# cat ifcfg-br-ex1
ONBOOT=yes
IPADDR=10.13.44.22
NETMASK=255.255.255.0
NETWORK=10.13.44.0
VLAN=yes
DEVICE=br-ex1
NAME=br-ex1
DEVICETYPE=ovs
OVSBOOTPROTO=static
TYPE=OVSBridge

[root@RDO network-scripts]# cat /etc/iproute2/rt_tables 
#
# reserved values
#
255 local
254 main
253 default
0   unspec
#
# local
#
#1  inr.ruhep
200 VLAN43
201 VLAN44

[root@RDO network-scripts]# cat route-br-ex
default via 10.13.43.1 dev br-ex table VLAN43

[root@RDO network-scripts]# cat route-br-ex1
default via 10.13.44.1 dev br-ex1 table VLAN44

 [root@RDO network-scripts]# cat rule-br-ex
    from 10.13.43.22/24 table VLAN43

    [root@RDO network-scripts]# cat rule-br-ex1
    from 10.13.44.22/24 table VLAN44

from the RDO node i can ping any ip in VLAN 43 {ping 10.13.43.x} or VLAN 44 {ping 10.13.44.x} but if i ping any other vlan i got network unreachable like dns server {ping 10.13.10.10} please help me with that configuration

Thanks.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2017-01-22 02:14:59 -0500

dbaxps gravatar image

Take a look at RDO Mitaka & Several External Networks VLAN Provider Setup
External vlan provider network has been utilized above, e.g. non-bridged external networking helps out.

edit flag offensive delete link more

Comments

hello dbaxps. thanks for your replay it doesn't work with me also but i will start fresh install and do another test

hossam gravatar imagehossam ( 2017-01-23 15:33:14 -0500 )edit
1

IT DOES WORK. Follow my post on Linux.com. Setup RDO Newton/Mitaka/Liberty install on virgin CentOS 7.3 box from scratch.
RDO Newton AIO Setup - http://lxer.com/module/newswire/view/...

dbaxps gravatar imagedbaxps ( 2017-01-23 16:12:55 -0500 )edit

yes i will start new installation from scratch using your setup in http://lxer.com/module/newswire/view/236067/index.html (link text)

i think i did wrong configuration before

thanks a lot for your help and support

hossam gravatar imagehossam ( 2017-01-24 16:45:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-01-22 00:16:07 -0500

Seen: 108 times

Last updated: Jan 22 '17