Ask Your Question
2

packstack install error with keystone

asked 2014-01-08 02:18:47 -0600

abnerch gravatar image

updated 2014-10-20 10:47:32 -0600

Installing Dependencies...                             [ DONE ]
Copying Puppet modules and manifests...                [ DONE ]
Applying Puppet manifests...
Applying 10.210.217.42_prescript.pp
10.210.217.42_prescript.pp :               [ DONE ]                   
Applying 10.210.217.42_mysql.pp
Applying 10.210.217.42_qpid.pp
10.210.217.42_mysql.pp :                       [ DONE ]           
10.210.217.42_qpid.pp :                         [ DONE ]          
Applying 10.210.217.42_keystone.pp
Applying 10.210.217.42_glance.pp
Applying 10.210.217.42_cinder.pp
                                                                                             [ ERROR ]

ERROR : Error appeared during Puppet run: 10.210.217.42_keystone.pp
Error: /Stage[main]/Keystone::Roles::Admin/Keystone_role[_member_]: Could not evaluate: Execution of '/usr/bin/keystone --endpoint http://127.0.0.1:35357/v2.0/ role-list' returned 2: usage: keystone [--version] [--timeout <seconds>]
You will find full trace in log /var/tmp/packstack/20140108-160410-JAqqiv/manifests/10.210.217.42_keystone.pp.log

Please check log file /var/tmp/packstack/20140108-160410-JAqqiv/openstack-setup.log for more information

anyone know how to solve this?

Preparing servers... [ DONE ] Installing Dependencies... [ DONE ] Copying Puppet modules and manifests... [ DONE ] Applying Puppet manifests... Applying 10.210.217.42_prescript.pp 10.210.217.42_prescript.pp : [ DONE ]
Applying 10.210.217.42_mysql.pp Applying 10.210.217.42_qpid.pp 10.210.217.42_mysql.pp : [ DONE ]
10.210.217.42_qpid.pp : [ DONE ]
Applying 10.210.217.42_keystone.pp Applying 10.210.217.42_glance.pp Applying 10.210.217.42_cinder.pp [ ERROR ]

ERROR : Error appeared during Puppet run: 10.210.217.42_keystone.pp Error: /Stage[main]/Keystone::Roles::Admin/Keystone_role[_member_]: Could not evaluate: Execution of '/usr/bin/keystone --endpoint http://127.0.0.1:35357/v2.0/ role-list' returned 2: usage: keystone [--version] [--timeout ] You will find full trace in log /var/tmp/packstack/20140108-160410-JAqqiv/manifests/10.210.217.42_keystone.pp.log Please check log file /var/tmp/packstack/20140108-160410-JAqqiv/openstack-setup.log for more information


anyone know how to solve this problem ??? 3Q very much~

edit retag flag offensive close merge delete

Comments

check Keystone logs /var/tmp/packstack/20140108-160410-JAqqiv/manifests/10.210.217.42_keystone.pp.log and add the relevant details to your question

smaffulli gravatar imagesmaffulli ( 2014-01-10 15:00:31 -0600 )edit
1

abnerch, is this still a problem? Can you post the contents of the log file as requested?

rbowen gravatar imagerbowen ( 2014-01-29 15:14:00 -0600 )edit

Anyone know the reason? In my case, the log shows me : Error: /Stage[main]/Swift::Keystone::Auth/Keystone_service[swift]: Could not evaluate: Execution of '/usr/bin/key stone --endpoint http://127.0.0.1:35357/v2.0/ service-list' returned 2: usage: keystone [--version] [--timeout <seconds>] I still not solve this problem, maybe the problem is on keystone. I set the bind_ip to 0.0.0.0 but not work.

Jay Chen gravatar imageJay Chen ( 2014-02-02 06:13:12 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-02-19 03:46:38 -0600

gounini gravatar image

updated 2014-02-19 03:51:21 -0600

Same problem for me.

  1. Install RHEL 6.5 x86_64
  2. yum install -y http://rdo.fedorapeople.org/rdo-release.rpm
  3. yum check-update && yum update && yum install openstack-packstack
  4. yum install -y --nogpgcheck http://mirror.centos.org/centos/6/os/i386/Packages/rubygems-1.3.7-5.el6.noarch.rpm (http://mirror.centos.org/centos/6/os/...) http://mirror.centos.org/centos/6/os/x86_64/Packages/python-jinja2-2.2.1-1.el6.x86_64.rpm (http://mirror.centos.org/centos/6/os/...) http://dl.fedoraproject.org/pub/epel/6/i386/python-jinja2-26-2.6-2.el6.noarch.rpm (http://dl.fedoraproject.org/pub/epel/...) http://dl.fedoraproject.org/pub/epel/6/i386/python-flask-0.9-5.el6.noarch.rpm (http://dl.fedoraproject.org/pub/epel/...) http://mirror.centos.org/centos/6/os/i386/Packages/python-sphinx-0.6.6-2.el6.noarch.rpm (http://mirror.centos.org/centos/6/os/...) http://dl.fedoraproject.org/pub/epel/6/i386/python-werkzeug-0.8.3-2.el6.noarch.rpm (http://dl.fedoraproject.org/pub/epel/...) http://mirror.centos.org/centos/6/os/i386/Packages/python-docutils-0.6-1.el6.noarch.rpm (http://mirror.centos.org/centos/6/os/...) http://mirror.centos.org/centos/6/os/x86_64/Packages/yum-plugin-priorities-1.1.30-14.el6.noarch.rpm (http://mirror.centos.org/centos/6/os/...) http://mirror.centos.org/centos/6/os/x86_64/Packages/dnsmasq-utils-2.48-13.el6.x86_64.rpm (http://mirror.centos.org/centos/6/os/...) http://mirror.centos.org/centos/6/os/x86_64/Packages/python-imaging-1.1.6-19.el6.x86_64.rpm (http://mirror.centos.org/centos/6/os/...)
  5. packstack --allinone

I get this error

ERROR : Error appeared during Puppet run: 192.168.41.10_keystone.pp
Error: /Stage[main]/Keystone::Roles::Admin/Keystone_role[_member_]: Could not evaluate: Execution of '/usr/bin/keystone --endpoint http://127.0.0.1:35357/v2.0/ role-list' returned 1: Forbidden (HTTP 403)
You will find full trace in log /var/tmp/packstack/20140218-171038-FTMoyW/manifests/192.168.41.10_keystone.pp.log
Please check log file /var/tmp/packstack/20140218-171038-FTMoyW/openstack-setup.log for more information

And /var/tmp/packstack/20140218-171038-FTMoyW/manifests/192.168.41.10_keystone.pp.log says :

Warning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults
Warning: Scope(Class[Nova::Keystone::Auth]): cinder parameter is deprecated and has no effect.
Warning: Scope(Class[Swift::Keystone::Auth]): Address parameter for swift::keystone::auth has been deprecated, use public_address instead
Notice: Compiled catalog for myhostname.mydomain.mytld in environment production in 1.98 seconds
Notice: /Stage[main]/Main/Add_allow_host[ALL]/Firewall[001 keystone incoming ALL]/ensure: created
Notice: /Stage[main]/Keystone/Package[keystone]/ensure: created
Notice: /Stage[main]/Keystone/File[/var/lib/keystone]/mode: mode changed '0755' to '0750'
Notice: /Stage[main]/Keystone/File[/var/cache/keystone]/ensure: created
Notice: /Stage[main]/Keystone/File[/etc/keystone]/owner: owner changed 'root' to 'keystone'
Notice: /Stage[main]/Keystone/File[/etc/keystone/keystone.conf]/owner: owner changed 'root' to 'keystone'
Notice: /Stage[main]/Keystone/File[/etc/keystone/keystone.conf]/mode: mode changed '0640' to '0600'
Notice: /Stage[main]/Keystone/Keystone_config[catalog/driver]/ensure: created
Notice: /Stage[main]/Keystone/Keystone_config[signing/token_format]/ensure: created
Notice: /Stage[main]/Keystone/Keystone_config ...
(more)
edit flag offensive delete link more

Comments

SOLVED Shame on me... packstack don't like export http_proxy... If you have this error and you use proxy, set it un your yum configuration, not as shell exported variable.

gounini gravatar imagegounini ( 2014-02-24 09:40:35 -0600 )edit

worked fine for me

kchhabra gravatar imagekchhabra ( 2016-06-22 13:31:04 -0600 )edit
0

answered 2014-05-21 09:37:03 -0600

kadoes gravatar image

updated 2014-05-21 09:37:34 -0600

ERROR : Error appeared during Puppet run: 10.210.217.42_keystone.pp Error: /Stage[main]/Keystone::Roles::Admin/Keystone_role[_member_]: Could not evaluate: Execution of '/usr/bin/keystone --endpoint http://127.0.0.1:35357/v2.0/ role-list' returned 2: usage: keystone [--version] [--timeout ]

AND This error in log file:

Execution of '/usr/bin/key stone --endpoint http://127.0.0.1:35357/v2.0/ service-list' returned 2: usage: keystone [--version] [--timeout ]

are caused by that you have not appropriate version of keystone. This steps should be solve your problem:

Check your version of keystone - /usr/bin/keystone --version If version of keystone is 0.7.1 downgrade to the 0.4.1 version - yum downgrade python-keystoneclient.noarch Make sure that now version of keystone is 0.4.1 - /usr/bin/keystone --version

edit flag offensive delete link more

Comments

I do not have a http_proxy as an export variable still it fails for me, can someone help

SB99 gravatar imageSB99 ( 2016-06-07 02:58:45 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-01-08 02:18:47 -0600

Seen: 8,254 times

Last updated: Oct 20 '14