OpenStack Juno Network problem

asked 2017-01-18 17:13:51 -0500

anonymous user

Anonymous

Hi, I used OpenStack version Juno. I have the problem with the network. I created tenant which have a three windows machines. There is the IP addressing of the network:

  • Default gateway: 192.168.1.1
  • Windows machine 1: 192.168.1.2
  • Windows machine 2: 192.168.1.3
  • Windows machine 3: 192.168.1.4

All these machines are assigned floating IPs. I can't ping any outside IPs but I can ping machines inside of the network. For example, from Windows machine 1 I can't ping google, but I can ping Windows machine 2 or 3. If I ping default gateway which has IP 192.168.1.1 I get "Unreachable" reply. The same problem I have with RDP. When I want to connect to the one of this machine with RDP from the outside network It fail. But when I go on one of this machine with console and then use RDP to connect to the another machine It works fine (for example RDP from Windows machine 1 to the Windows machine 2 or 3 works fine).

So obviously I have problem with the neutron network. I can't access to the internet and machines are not accessible from the internet.

Has anyone idea what is reason for this problem? How can I trubleshooting this problem with the network? I'm a begginer if we are talking about OpenStack so any help is welcome.

edit retag flag offensive close merge delete

Comments

1

If I understand correct, your tenant machines are not able to reach the tenant router / gateway running in Controller node(s).

What kind of tunnel setup between Controller and Compute nodes? More information about your Neutron setup will be helpful.

Moorthy gravatar imageMoorthy ( 2017-01-19 06:11:42 -0500 )edit

Yes, you understand correctly. Everything working fine and at the one moment network stop working for some customer. There is no special connection between controller and compute nodes - classic IPv4 connection.

I found that the instances doesn't have mac addresses of the default gateway router.

cloudadmin gravatar imagecloudadmin ( 2017-01-20 11:16:31 -0500 )edit

The quick solution which is good for now but not for the feature is that I remove all floating IPs and also remove all interfaces from the router and delete router of tenant. Then I create a new router with the same name and append the same interfaces of external and internal network.

cloudadmin gravatar imagecloudadmin ( 2017-01-20 11:20:37 -0500 )edit

And after that I revert all public (floating) IP addresses to the instances. That works but it is not a solution. I have one tenant which have two windows instances and that works only for one instance - the second instance is still unconnected. Do you have any idea about the reason of this problem?

cloudadmin gravatar imagecloudadmin ( 2017-01-20 11:23:21 -0500 )edit