Ask Your Question
0

[Neutron Error] CreateVM, Failed to bind port

asked 2017-01-18 04:53:07 -0500

SeanLin gravatar image

Hi,All. First Thanks for viewing my error.

I have an controller node named controller I have another node named ictcomp6 seen as network and compute node. My OS is Ubuntu Server 14.04 And My Openstack Version is Liberty.

When I create the vm, it shows building failed. And I check the /var/log/neutron/neutron-server.log in host controller

2017-01-18 17:06:15.860 2716 ERROR neutron.plugins.ml2.managers [req-87661b94-21d8-4dc7-a04c-c32ca2c40648 9d6d163376474a2dab25f2dfbabfe180 069d900c047e48faaaaf8b05e2701eb5 - - -] Failed to bind port 12b217cf-7b4a-43a7-ad50-fd46f09ea423 on host ictcomp6 for vnic_type normal using segments [{'segmentation_id': None, 'physical_network': None, 'id': u'845f4fd1-3944-4d22-91c0-386705c58cd7', 'network_type': u'local'}] 2017-01-18 17:06:15.861 2716 INFO neutron.plugins.ml2.plugin [req-87661b94-21d8-4dc7-a04c-c32ca2c40648 9d6d163376474a2dab25f2dfbabfe180 069d900c047e48faaaaf8b05e2701eb5 - - -] Attempt 2 to bind port 12b217cf-7b4a-43a7-ad50-fd46f09ea423 2017-01-18 17:06:15.867 2716 ERROR neutron.plugins.ml2.managers [req-87661b94-21d8-4dc7-a04c-c32ca2c40648 9d6d163376474a2dab25f2dfbabfe180 069d900c047e48faaaaf8b05e2701eb5 - - -] Failed to bind port 12b217cf-7b4a-43a7-ad50-fd46f09ea423 on host ictcomp6 for vnic_type normal using segments [{'segmentation_id': None, 'physical_network': None, 'id': u'845f4fd1-3944-4d22-91c0-386705c58cd7', 'network_type': u'local'}]


The following is my setting. /etc/network/interfaces in host ictcomp6

auto eth0
iface eth0 inet static
address 192.168.1.11
netmask 24
gateway 192.168.1.1
dns-nameservers 8.8.8.8

auto eth1
iface eth1 inet manual
up ip link set $IFACE up
up ip address add 0/0 dev $IFACE
down ip link set $IFACE down

PS. eth0 is the network to communicate hosts

ps. eth1 is the network i expect to let vm's network can go public.


And Below is my ovs-vsctl show in host ictcomp6

f39c3752-580e-49e1-8690-e4f92dc05d1a
Bridge br-ex
    fail_mode: secure
    Port phy-br-ex
        Interface phy-br-ex
            type: patch
            options: {peer=int-br-ex}
    Port "eth1"
        Interface "eth1"
    Port br-ex
        Interface br-ex
            type: internal
Bridge br-int
    fail_mode: secure
    Port int-br-ex
        Interface int-br-ex
            type: patch
            options: {peer=phy-br-ex}
    Port br-int
        Interface br-int
            type: internal
    Port "tap198729da-eb"
        Interface "tap198729da-eb"
            type: internal
    Port "tapf0e7c60b-a3"
        Interface "tapf0e7c60b-a3"
            type: internal
    Port patch-tun
        Interface patch-tun
            type: patch
            options: {peer=patch-int}
Bridge br-tun
    fail_mode: secure
    Port br-tun
        Interface br-tun
            type: internal
    Port patch-int
        Interface patch-int
            type: patch
            options: {peer=patch-tun}
ovs_version: "2.4.1"

Could anyone give me some advices.

Thanks a lot again.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-01-18 15:26:14 -0500

segmentation_id': None, 'physical_network': None, 'id': u'845f4fd1-3944-4d22-91c0-386705c58cd7', 'network_type': u'local'

Network type "local" only makes sense in an all-in-one setup. Your ML2 config is wrong, perhaps the default tenant network setting?

edit flag offensive delete link more

Comments

Thanks for replying very much!! I create an vxlan network again, but it still has an error. Failed to bind port ... on host ictcomp6 for vnic_type normal using segments [{'segmentation_id': 94, 'physical_network': None, 'id': u'9edeb648-3c5f-498a-8766-5e89af241a3c', 'network_type': u'vxlan}]

SeanLin gravatar imageSeanLin ( 2017-01-19 04:14:00 -0500 )edit

And it is my /etc/neutron/plugin/ml2/ml2.conf.ini setting in ictcomp6

[ml2] type_drivers = flat,vlan,gre,vxlan

tenant_network_types = vxlan

mechanism_drivers = openvswitch,l2population

extension_drivers = port_security

[ml2_type_flat]

flat_networks = external

SeanLin gravatar imageSeanLin ( 2017-01-19 04:16:24 -0500 )edit

[ml2_type_vxlan]

vni_ranges = 1:1000

[securitygroup]

enable_ipset = True

SeanLin gravatar imageSeanLin ( 2017-01-19 04:16:52 -0500 )edit

"physical network none" doesn't look correct. Please compare your config with http://docs.openstack.org/newton/netw...

Bernd Bausch gravatar imageBernd Bausch ( 2017-01-19 08:57:27 -0500 )edit

When I change my l3-agent.ini file following the document, interface_driver = openvswitch, my l3 service is dead. I check the error in l3_agent.log, it shows CRITICAL neutron [-] ValueError: Empty module name Thanks again !

SeanLin gravatar imageSeanLin ( 2017-01-19 12:16:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-01-18 03:29:13 -0500

Seen: 5,691 times

Last updated: Jan 18 '17