Ask Your Question
0

Establishing Instance Internet Connectivity with Kolla

asked 2017-01-17 05:54:32 -0500

thomas.oneill gravatar image

Hello,

This is my current architecture: https://www.lucidchart.com/invitations/accept/43422ede-d5cd-4ca1-bd85-e1066dd7ac36 (https://www.lucidchart.com/invitation...)

Here's the output of my ip addr on my compute node:

stack@compute00:~ $ ip a
1: lo: <loopback,up,lower_up> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eno1: <broadcast,multicast> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 0c:c4:7a:6c:1a:a0 brd ff:ff:ff:ff:ff:ff
3: eno2: <broadcast,multicast> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 0c:c4:7a:6c:1a:a1 brd ff:ff:ff:ff:ff:ff
4: ens2f0: <broadcast,multicast> mtu 1500 qdisc noop master ovs-system state DOWN group default qlen 1000
    link/ether 0c:c4:7a:bb:96:4c brd ff:ff:ff:ff:ff:ff
5: ens2f1: <broadcast,multicast,up,lower_up> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 0c:c4:7a:bb:96:4d brd ff:ff:ff:ff:ff:ff
    inet 10.10.10.11/24 brd 10.10.10.255 scope global ens2f1
       valid_lft forever preferred_lft forever
    inet 10.10.10.12/32 scope global ens2f1
       valid_lft forever preferred_lft forever
    inet6 fe80::ec4:7aff:febb:964d/64 scope link
       valid_lft forever preferred_lft forever
6: docker0: <no-carrier,broadcast,multicast,up> mtu 1500 qdisc noqueue state DOWN group default
    link/ether 02:42:6f:2a:3e:d8 brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 scope global docker0
       valid_lft forever preferred_lft forever
7: ovs-system: <broadcast,multicast> mtu 1500 qdisc noop state DOWN group default qlen 1
    link/ether 42:f8:8d:4d:3a:36 brd ff:ff:ff:ff:ff:ff
8: br-ex: <broadcast,multicast> mtu 1500 qdisc noop state DOWN group default qlen 1
    link/ether 0c:c4:7a:bb:96:4c brd ff:ff:ff:ff:ff:ff
9: br-int: <broadcast,multicast> mtu 1450 qdisc noop state DOWN group default qlen 1
    link/ether 8e:13:f0:66:e8:45 brd ff:ff:ff:ff:ff:ff
13: br-tun: <broadcast,multicast> mtu 1500 qdisc noop state DOWN group default qlen 1
    link/ether ba:f5:cb:4b:06:4e brd ff:ff:ff:ff:ff:ff
14: qbr1eeaa859-bc: <broadcast,multicast,up,lower_up> mtu 1450 qdisc noqueue state UP group default qlen 1000
    link/ether fa:65:a3:35:17:ab brd ff:ff:ff:ff:ff:ff
15: qvo1eeaa859-bc@qvb1eeaa859-bc: <broadcast,multicast,promisc,up,lower_up> mtu 1450 qdisc noqueue master ovs-system state UP group default qlen 1000
    link/ether d2:2f:d6:d7:d2:a5 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::d02f:d6ff:fed7:d2a5/64 scope link
       valid_lft forever preferred_lft forever
16: qvb1eeaa859-bc@qvo1eeaa859-bc: <broadcast,multicast,promisc,up,lower_up> mtu 1450 qdisc noqueue master ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-01-18 02:44:53 -0500

thomas.oneill gravatar image

updated 2017-01-18 03:14:20 -0500

I established network connectivity yesterday evening!

The main problem I was having was that both br-ex and br-tun were down, which seems to be the behaviour every time I deploy OpenStack using Kolla/Ansible, as well as on reboot.

Strangely however, with my successful ping I am not seeing the traffic on either br-ex or br-tun when packet capturing either interface during the successful ping from the instance. I am seeing the traffic on:

  • Both sides of the veth pair (looks like qvb73d1a05c-a9@qvo73d1a05c-a9 for me in ip addr, the @ is the separator).
  • The TAP device.
  • My external interface which OVS's br-ex is supposedly bridged to for Neutron's external connectivity (neutron_external_interface), for me this is ens2f0.
  • Both interfaces of the router if I ip netns exec [router_id] bash to check.

I'll do some more investigation and then potentially post a further question(s) to work out exactly what is going on here.

edit flag offensive delete link more

Comments

I have the same issue with br-ex and br-tun being down. How did you manage to start those two interfaces ?

kyomster gravatar imagekyomster ( 2017-07-31 08:31:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-01-17 05:54:32 -0500

Seen: 457 times

Last updated: Jan 18 '17