Ask Your Question

Confused About neutron_external_interface

asked 2017-01-16 06:44:46 -0600

thomas.oneill gravatar image


About this neutron_external_interface in etc/kolla/globals.yml the following is stated:

This is the raw interface given to neutron as its external network port. Even though an IP address can exist on this interface, it will be unusable in most configurations. It is recommended this interface not be configured with any IP addresses for that reason. (

I'm trying to figure out how I'm supposed to interpret this in terms of how I can actually implement this to get my instances online.

At the moment I have a multinode setup with a controller and a compute node. I've used kolla-ansible to deploy. I have 2 interfaces on each host, ens2f0 and ens2f1. The ens2f0's are the external public interfaces with public IP addresses. The ens2f1's are the internal interfaces and have an RFC 1918 address on.

Looking at what it says I guess I'm not supposed to just make the neutron_external_interface the ens2f0? I actually tried this and it broke connectivity to the compute node I think. So am I supposed to make a loopback or bridge interface and use that, or what?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2017-01-17 05:33:57 -0600

thomas.oneill gravatar image

updated 2017-01-18 02:58:19 -0600

Folks in the #openstack-kolla channel answered this for me saying that the neutron_external_interface should be an interface that will be able to reach the internet, it will be added to the br-ex bridge interface (layer 2), the IP (layer 3) configuration will be managed by Neutron/OpenVSwitch.

I'm still having problems at the moment though, my br-ex is showing as DOWN in my IP configuration, I'm going to post a new question about this and link to that from this answer when I've posted it.

Edit: This was follow-up question: (

edit flag offensive delete link more


That interface is supposed to be down. Note: Alot of people had issues in a virtualized environment if this is your case make sure the virtualbox nic has the promisicious mode set to allow all.

shotoflove gravatar imageshotoflove ( 2019-05-20 11:50:17 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-01-16 06:44:46 -0600

Seen: 1,589 times

Last updated: Jan 18 '17