Ask Your Question
0

Suppose I have 2 NICs in my network deployement - 1 for public and 1 for private, should DHCP(dnsmasq) run on both the interfaces

asked 2014-01-07 21:55:04 -0600

Savanna gravatar image

updated 2014-01-22 15:12:38 -0600

Evgeny gravatar image

Should dnsmasq run on both the interfaces? By default pxe boots from eth0, and slave nodes get ips from the fuel master but after that it goes into "network auto config failed".

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-01-08 00:15:38 -0600

dheeru gravatar image

dnsmasq listens on DHCP requests coming from the different interfaces. I'm sure your vms are supposed to get the IP address from DHCP on private NIC. For public NIC generally we don't have DHCP requirements. So DHCP responding for requests coming on private NIC, it should be sufficient.

edit flag offensive delete link more

Comments

Hi Thank you for the reply. But my doubt still remains... 1. The slave nodes get an IP for pxe boot from Master node via DHCP and then installation of OS and OpenStack should continue. But my installation stops midway near "Configuring DHCP" saying "DHCP not found or slow " something like that. So I simply connected eth1 to the port meant for eth0(alongside eth0) and then installation continued. It means that slave nodes DHCP is looking for both eth0 and eth1 which is odd, because eth0 is the defiualt for pxe boot. I am unable to understand why it is looking for DHCP on eth1 also. Can you tell me any possible reasons(as I am out of ideas) so that I can trace back and fix. Thank you.

Savanna gravatar imageSavanna ( 2014-01-09 23:07:31 -0600 )edit

It looks strange to me. You can try enabling DHCP on both eth1 and eth2. Otherwise you can hard/code IP address and continue. That is better I feel.

dheeru gravatar imagedheeru ( 2014-01-14 00:27:09 -0600 )edit

Hi Dheeru, I want to mention that I got local link address, Got IPv6 auto configuration but as usual it failed in" configuring with DHCP" step. So I choose the option "manual configuration" and it is again asking for eth0 address !!! Now I am wondering why because eth0 already gets an address in pxe booting.

Savanna gravatar imageSavanna ( 2014-01-19 23:48:33 -0600 )edit

And also it says "failed to download preconfiguration file" ! What can be done about this ?

Savanna gravatar imageSavanna ( 2014-01-19 23:50:02 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-07 21:55:04 -0600

Seen: 278 times

Last updated: Jan 08 '14