Ask Your Question
0

havana with floodlight (no devstack)

asked 2014-01-07 21:03:12 -0500

seraphboy gravatar image

updated 2014-01-07 22:38:13 -0500

Hi,

I have 3 nodes: controller, network and compute, and use ubuntu12.04. I want to install floodlight in network node, use this document https://wiki.openstack.org/wiki/Neutron/FloodlightPluginSetup , http://www.openflowhub.org/display/floodlightcontroller/Neutron+REST+Proxy+Plugin+READMEv2 , but something confuse me:

It said "There is no quantum--agent service that should runs on the compute hosts ", and if not install neutron--agent, how can I config neutron in compute node? there is no /etc/neutron/neutron.conf.

please tell me,thanks

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-01-07 22:41:32 -0500

joshua gravatar image

Hi,

I am also trying it out. As far as my understanding goes, there is no need of neutron in Compute node. Only you have to execute sudo ovs-vsctl --no-wait add-br br-int sudo ip link set dev eth1 up sudo ovs-vsctl --no-wait br-set-external-id br-int bridge-id br-int sudo ovs-vsctl --no-wait set-controller br-int tcp:192.168.195.244:6633

ovs-vsctl -- --may-exist add-port br-int eth1 on the compute node to point to the network node

Please share details if there is success.

edit flag offensive delete link more

Comments

Thank you! This problem troubles me few days. I have execute these commands and when I use neutron command it shows error "Unauthorized: Authentication required". there must be something wrong on controller node, I'll try to find the issue and then check the neutron config.

seraphboy gravatar imageseraphboy ( 2014-01-07 23:27:21 -0500 )edit

Hi, joshua, I can successfully create network, and they can be showed in "neutron net-list" command, but I cannot create instance, and the log said "NoNetworksFound: No networks defined" ,also,there is nothing in "nova network-list".

seraphboy gravatar imageseraphboy ( 2014-01-08 02:39:04 -0500 )edit

Check the network to which the tenant belongs. Try to create the instance using the User credentials belonging to the tenant. It will work. You have to source your user credentials approprately

joshua gravatar imagejoshua ( 2014-01-09 01:59:23 -0500 )edit

it worked, but the network is...terrible.

seraphboy gravatar imageseraphboy ( 2014-01-09 03:29:44 -0500 )edit

on compute-node, Is there any tapxxxxx on br-int ? If have, how to conf ?

seraphboy gravatar imageseraphboy ( 2014-01-13 03:36:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-07 21:03:12 -0500

Seen: 236 times

Last updated: Jan 07 '14