neutron services not starting up

asked 2017-01-12 11:19:33 -0600

os-noob gravatar image

updated 2017-01-24 14:30:05 -0600

rbowen gravatar image

I have an OpenStack Liberty installation that was working perfectly fine until a few moments back. I tried to install lbaas based on the article: http://docs.openstack.org/liberty/net... and everything got messed up. I reverted the changes, still it doesn't work.

I see the following in /var/log/syslog:

Jan 12 18:14:36 controller01 kernel: [ 3471.324270] init: neutron-ovs-cleanup pre-start process (23833) terminated with status 1
Jan 12 18:14:36 controller01 kernel: [ 3471.327555] init: wait-for-state (neutron-l3-agentneutron-ovs-cleanup) main process (23820) killed by TERM signal
Jan 12 18:14:36 controller01 kernel: [ 3471.327822] init: wait-for-state (neutron-dhcp-agentneutron-ovs-cleanup) main process (23828) killed by TERM signal
Jan 12 18:14:36 controller01 kernel: [ 3471.850642] init: neutron-metadata-agent main process (23859) terminated with status 1
Jan 12 18:14:36 controller01 kernel: [ 3471.850652] init: neutron-metadata-agent main process ended, respawning
Jan 12 18:14:36 controller01 kernel: [ 3472.077941] init: neutron-dhcp-agent main process (23874) terminated with status 1
Jan 12 18:14:36 controller01 kernel: [ 3472.077952] init: neutron-dhcp-agent main process ended, respawning
Jan 12 18:14:37 controller01 kernel: [ 3472.150238] init: neutron-l3-agent main process (23873) terminated with status 1
Jan 12 18:14:37 controller01 kernel: [ 3472.150250] init: neutron-l3-agent main process ended, respawning
Jan 12 18:14:37 controller01 kernel: [ 3472.462773] init: neutron-server main process (23848) terminated with status 1
Jan 12 18:14:37 controller01 kernel: [ 3472.462784] init: neutron-server main process ended, respawning
Jan 12 18:14:37 controller01 kernel: [ 3472.562763] init: neutron-metadata-agent main process (23904) terminated with status 1
Jan 12 18:14:37 controller01 kernel: [ 3472.562777] init: neutron-metadata-agent main process ended, respawning
Jan 12 18:14:37 controller01 kernel: [ 3472.765588] init: neutron-ovs-cleanup pre-start process (23925) terminated with status 1
Jan 12 18:14:37 controller01 kernel: [ 3472.769266] init: wait-for-state (neutron-dhcp-agentneutron-ovs-cleanup) main process (23919) killed by TERM signal
Jan 12 18:14:37 controller01 kernel: [ 3472.769525] init: wait-for-state (neutron-l3-agentneutron-ovs-cleanup) main process (23932) killed by TERM signal

These messages just keep on repeating. I think its a problem with the process neutron-ovs-cleaup not exiting properly. However there is nothing in the ovs-cleanup.log:

2017-01-12 16:02:11.706 1208 INFO neutron.common.config [-] Logging enabled!
2017-01-12 16:02:11.707 1208 INFO neutron.common.config [-] /usr/bin/neutron-ovs-cleanup version 7.1.1
2017-01-12 16:02:11.899 1208 INFO neutron.cmd.ovs_cleanup [-] Cleaning bridge: br-int
2017-01-12 16:02:14.354 1208 INFO neutron.cmd.ovs_cleanup [-] Cleaning bridge: br-ex
2017-01-12 16:02:14.516 1208 INFO neutron.cmd.ovs_cleanup [-] OVS cleanup completed successfully

I'm able to manually start these processes like neutron-server, neutron-dhcp-agent etc. However starting them via the kernel fails. But starting ovs-cleaup using the command service neutron-ovs-cleaup start fails.

I'm not sure what more I should be doing here. There isn't any more information in the logs. Any help is appreciated.

edit retag flag offensive close merge delete

Comments

Have you checked the logs of the failing services, e.g. /var/log/neutron/neutron-server.log for the neutron server? How do you start them manually, and how are they started automatically?

Bernd Bausch gravatar imageBernd Bausch ( 2017-01-12 17:12:07 -0600 )edit