ARM vms using x86_64 (default) emulator

asked 2017-01-10 18:49:45 -0600

Eric Renouf gravatar image

updated 2017-01-24 14:22:45 -0600

rbowen gravatar image

I'm sure it's a step that I am missing or doing wrong. I just used fuel to deploy an openstack setup using Ubuntu for the compute nodes (and controllers). Fuel is able to start its VMs and passes all its health checks.

I thought it would be interesting then to try to deploy an ARM VM and have it be emulated, which I had thought would work. I downloaded the Ubuntu Trusty ARM 64 bit kernel+image (from here). I added the kernel as an AKI image type, then added the disk image as an AMI with the associated kernel, and set the architecture to aarch64.

Using vimsh capabilities on the compute nodes includes an entry for aarch64, so I believe this should be supported. Also, I think openstack accepts that because if I have a typo in that name it will reject it, but otherwise it accepts it.

Whenever I try to create an instance from that image though it uses qemu-system-x86_64 as the emulator, not qemu-system-arm or similar, and predictably the system does not end up usable.

I haven't seen anything that is a clue for me about what's going on when I look in either /var/log/nova-all.log nor in /var/log/nova/nova-compute.log. Where should I look for clues, or what step am I likely overlooking to make this work?

edit retag flag offensive close merge delete

Comments

Hi, have you managed to boot an ARM instance on x86_64? Trying to do the same thing, but it just does not seem working. Please let me know if you found the solution.

mikeaz87 gravatar imagemikeaz87 ( 2018-05-31 05:42:58 -0600 )edit