Ask Your Question
0

Documentation for Installing ceilometer not correct

asked 2017-01-05 22:53:15 -0600

DarkKnight gravatar image

I have religiously followed the documentation found here for installing ceilometer services. I have noticed that the documentation is not correct.

Under the configure the "Apache HTTP Server" section, the documentation suggests to add these entries in the /etc/httpd/conf.d/wsgi-ceilometer.conf file.

Listen 8777

<VirtualHost *:8777>
    WSGIDaemonProcess ceilometer-api processes=2 threads=10 user=ceilometer group=ceilometer display-name=%{GROUP}
    WSGIProcessGroup ceilometer-api
    WSGIScriptAlias / /usr/lib/python2.7/site-packages/ceilometer/api/app.wsgi
    WSGIApplicationGroup %{GLOBAL}
    ErrorLog /var/log/httpd/ceilometer_error.log
    CustomLog /var/log/httpd/ceilometer_access.log combined </VirtualHost>

WSGISocketPrefix /var/run/httpd

However , if you look closely, the ceilometer-api service also listens for requests on 8777 port, thus causing a conflict. In my case, i have changed the port in the wsgi-ceilometer.conf file to 8778. Ans that works ,as expected, properly. This post is not a question, but an attempt to know about how can i point this to the documentation team, so that others dont suffer as i did. Can anyone point me to the links or suggest the steps.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2017-01-06 06:12:38 -0600

updated 2017-01-06 06:16:11 -0600

First, please don't use draft documentation. Unfortunately, this is not that obvious from the page you refer to, but your URL http://docs.openstack.org/project-ins...draft/install-base-rdo.html contains the word "draft".

Second, if you find errors on current (neither draft nor outdated) doc pages, use the cute little bug link at the top or the bottom of the page to submit a bug. It's roughly as painless as using this forum, and it ensures you get the attention of the documentation team. If it turns out not to be a bug but a misconception on your side, it might still trigger some improvement to remove future misconceptions.

Having said that, yprokule's answer seems to be correct.

edit flag offensive delete link more
1

answered 2017-01-06 05:53:30 -0600

yprokule gravatar image

ceilometer-api is running from under Apache's mod_wsgi, hence U don't need to start a service on it's own. I mean systemctl start openstack-ceilometer-api.service is not required anymore.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-01-05 22:53:15 -0600

Seen: 83 times

Last updated: Jan 06 '17