Ask Your Question
0

devstack mitaka gives error on running stack.sh after rebooting VM

asked 2017-01-01 16:47:48 -0500

Shri gravatar image

updated 2017-01-04 10:32:46 -0500

zaneb gravatar image

Hi,

Facing error with devstack mitaka after running heat stack test with rally and rebooting the VM. Kindly help to understand and resolve the error. Kindly let know if clarification is required w.r.t sequence of test steps performed or logs generated.

Sequence of steps performed is as under:

Installed devstack mitaka on ubuntu 14.04, running stack.sh Run Rally test case to create and delete heat stack with neutron (samples/tasks/scenarios/heat/create-and-delete-stack-with-neutron.json) Run unstack.sh Reboot the ubuntu 14.04 Vm Run stack.sh throws error as under:

2017-01-01 15:20:45.122 | +lib/nova_plugins/functions-libvirt:configure_libvirt:111  local 'log_filters=1:libvirt.c 1:qemu 1:conf 1:security 3:object 3:event 3:json 3:file 1:util 1:qemu_monitor'
2017-01-01 15:20:45.126 | +lib/nova_plugins/functions-libvirt:configure_libvirt:115  local log_outputs=1:file:/var/log/libvirt/libvirtd.log
2017-01-01 15:20:45.129 | +lib/nova_plugins/functions-libvirt:configure_libvirt:116  sudo grep -q '^log_filters="1:libvirt.c 1:qemu 1:conf 1:security 3:object 3:event 3:json 3:file 1:util 1:qemu_monitor"' /etc/libvirt/libvirtd.conf
2017-01-01 15:20:45.139 | +lib/nova_plugins/functions-libvirt:configure_libvirt:119  sudo grep -q '^log_outputs="1:file:/var/log/libvirt/libvirtd.log"' /etc/libvirt/libvirtd.conf
2017-01-01 15:20:45.146 | +lib/nova_plugins/functions-libvirt:configure_libvirt:126  [[ -f /usr/share/libvirt/cpu_map.xml ]]
2017-01-01 15:20:45.166 | +lib/nova_plugins/functions-libvirt:configure_libvirt:127  sudo /home/shri/devstack/tools/cpu_map_update.py /usr/share/libvirt/cpu_map.xml
2017-01-01 15:20:45.357 | +lib/nova_plugins/functions-libvirt:configure_libvirt:134  stop_service libvirt-bin
2017-01-01 15:20:45.360 | +functions-common:stop_service:2276        is_ubuntu
2017-01-01 15:20:45.364 | +functions-common:is_ubuntu:465            [[ -z deb ]]
2017-01-01 15:20:45.368 | +functions-common:is_ubuntu:468            '[' deb = deb ']'
2017-01-01 15:20:45.371 | +functions-common:stop_service:2277        sudo /usr/sbin/service libvirt-bin stop
2017-01-01 15:20:45.378 | stop: Unknown instance:
2017-01-01 15:20:45.383 | +functions-common:stop_service:1           exit_trap
2017-01-01 15:20:45.386 | +./stack.sh:exit_trap:474                  local r=1
2017-01-01 15:20:45.390 | ++./stack.sh:exit_trap:475                  jobs -p
2017-01-01 15:20:45.394 | +./stack.sh:exit_trap:475                  jobs=
2017-01-01 15:20:45.398 | +./stack.sh:exit_trap:478                  [[ -n '' ]]
2017-01-01 15:20:45.403 | +./stack.sh:exit_trap:484                  kill_spinner
2017-01-01 15:20:45.407 | +./stack.sh:kill_spinner:370               '[' '!' -z '' ']'
2017-01-01 15:20:45.411 | +./stack.sh:exit_trap:486                  [[ 1 -ne 0 ]]
2017-01-01 15:20:45.414 | +./stack.sh:exit_trap:487                  echo 'Error on exit'
2017-01-01 15:20:45.415 | Error on exit
2017-01-01 15:20:45.419 | +./stack.sh:exit_trap:488                  generate-subunit 1483283858 187 fail
2017-01-01 15:20:45.910 | +./stack.sh:exit_trap:489                  [[ -z /opt/stack/logs ]]
2017-01-01 15:20:45.913 | +./stack.sh:exit_trap:492                  /home/shri/devstack/tools/worlddump.py -d /opt/stack/logs
2017-01-01 15:20:47.191 | +./stack.sh:exit_trap:498                  exit 1
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-02-28 13:54:28 -0500

Looks like this problem was fixed in a later devstack release with this patch: https://review.openstack.org/#/c/324562/2 (https://review.openstack.org/#/c/3245...)

So I guess if you want to fix this for the mitaka release you can try doing the same changes, just replace these two lines here https://github.com/openstack-dev/devstack/blob/stable/mitaka/lib/nova_plugins/functions-libvirt#L134 (https://github.com/openstack-dev/devs...)

stop_service $LIBVIRT_DAEMON
start_service $LIBVIRT_DAEMON

With this one:

restart_service $LIBVIRT_DAEMON

Then try running stack.sh again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-01-01 16:47:48 -0500

Seen: 132 times

Last updated: Feb 28 '17