can't get IP when I working with ml2 GRE [closed]

asked 2014-01-07 01:13:00 -0600

chen-li gravatar image

updated 2014-04-15 12:20:12 -0600

rbowen gravatar image

Hi list,

I'm working under Centos 6.4 + Havana.

I have three nodes working:

server node: running neutron-server

network node: running neutron-openvswitch-agent and neutron-dhcp-agent

compute node: running neutron-openvswitch-agent

I created a gre network and booted a instance successfully.

No error can be found in log.

But, my instance can't get IP from dhcp agent.

At network node, I can observed observed the DHCP request can be received, but it complains can't reach the ICMP host :

tcpdump -i eth4

14:31:51.314974 IP > GREv0, key=0x1, length 350: IP > BOOTP/DHCP, Request from fa:16:3e:73:dc:7a (oui Unknown), length 300
14:31:51.315028 IP > ICMP host unreachable - admin prohibited, length 378

Anyone know why this happen ??????



edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by rbowen
close date 2014-06-05 12:00:15.228692



Although you haven't received any answers to this, I've seen other posts from you later that seemed to indicate that you'd moved on past this issue. Is that the case? Are you still experiencing this problem?

rbowen gravatar imagerbowen ( 2014-04-15 12:19:26 -0600 )edit

Yes. It is caused by fireware.

Run command "/usr/share/openvswitch/scripts/ovs-ctl enable-protocol" on both compute node and dhcp node can work this out.

The most strange thing is, when I enable GRE at the very first beginning, it can work well. After a while, like one day off, this issue came.

chen-li gravatar imagechen-li ( 2014-04-15 21:02:19 -0600 )edit