Ask Your Question
0

Keystone: Not Authorized to perform the requested action

asked 2016-12-24 21:03:35 -0500

I installed keystone from source, configure manually, and successfully integrate with Apache's WSGI. I followed the procedure on openstack's newton for keystone as initial configuration (DB, bootstrap, etc). I can perform the query for following action: http://paste.openstack.org/show/593316/

But I couldn't perform authorized command even though I already configure OS parameter: http://paste.openstack.org/show/593317/

I am not sure which part I missed, tried to destroy database, recreate and follow again the procedure but result is same. It seems like openstack command doesn't take OS_PASSWORD environment variable when submitting the request?

edit retag flag offensive close merge delete

Comments

By default, you need the admin role when you create a user. The token issue command indicates that your password is correct. I would check the role assignments. Perhaps keystone-manage doctor reveals something. Or the Apache logs. Or worst case check the database directly.

Bernd Bausch gravatar imageBernd Bausch ( 2016-12-25 20:56:41 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-12-25 21:32:24 -0500

silently gravatar image

keystone.conf :

If set to true, strict password length checking is performed for password

manipulation. If a password exceeds the maximum length, the operation will

fail with an HTTP 403 Forbidden error. If set to false, passwords are

automatically truncated to the maximum length. (boolean value)

strict_password_check = false

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-12-24 21:03:35 -0500

Seen: 99 times

Last updated: Dec 25 '16