Ask Your Question
0

Instances stuck on "Booting from Hard Drive"

asked 2016-12-23 07:45:44 -0500

DJ Kill gravatar image

CentOS 7.3 OpenStack Newton release. All deployed with packstack.

Then I try to boot any instance from Horizon (I try Cirros and Fedora images) from OpenStack instance comes in "Running" state. but in console I see only "Booting from Hard Disk" and nothing more.

Check glance/nova/cinder logs for any related errors and nothing there.

Instance starts finally with that command:

usr/libexec/qemu-kvm -name guest=instance-00000006,debug-threads=on -S -object secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-4-instance-00000006/master-key.aes -machine pc-i440fx-rhel7.3.0,accel=kvm,usb=off -cpu Haswell-noTSX,+vme,+ds,+ss,+ht,+vmx,+osxsave,+f16c,+rdrand,+hypervisor,+arat,+tsc_adjust,+xsaveopt,+pdpe1gb,+abm -m 2048 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid 6cb695c8-10aa-4b97-83a8-a0259b644bc8 -smbios type=1,manufacturer=RDO,product=OpenStack Compute,version=14.0.2-1.el7,serial=51dd1b04-8972-401b-8e40-d94edb1af456,uuid=6cb695c8-10aa-4b97-83a8-a0259b644bc8,family=Virtual Machine -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-4-instance-00000006/monitor.sock,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -global kvm-pit.lost_tick_policy=discard -no-hpet -no-shutdown -boot strict=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=/dev/disk/by-path/ip-10.50.215.40:3260-iscsi-iqn.2010-10.org.openstack:volume-e3ea1f96-5b54-4242-863c-ae87de191811-lun-0,format=raw,if=none,id=drive-virtio-disk0,serial=e3ea1f96-5b54-4242-863c-ae87de191811,cache=none,aio=native -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x4,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -netdev tap,fd=30,id=hostnet0,vhost=on,vhostfd=32 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=fa:16:3e:17:5a:59,bus=pci.0,addr=0x3 -add-fd set=2,fd=34 -chardev file,id=charserial0,path=/dev/fdset/2,append=on -device isa-serial,chardev=charserial0,id=serial0 -chardev pty,id=charserial1 -device isa-serial,chardev=charserial1,id=serial1 -device usb-tablet,id=input0,bus=usb.0,port=1 -vnc 0.0.0.0:1 -k en-us -device cirrus-vga,id=video0,bus=pci.0,addr=0x2 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x5 -msg timestamp=on

Can you guide me where to look to find the problem?

edit retag flag offensive close merge delete

Comments

I've run into the same exact issue. Something to note: I was able to get .ISO images to boot. RAW and QCOW2 images fail to boot when Launched into Instances. When I check the Console all it shows is "Booting from Hard Drive". All OpenStack service are running. I can find no specific errors in logs.

BigQEd gravatar imageBigQEd ( 2017-01-03 08:16:12 -0500 )edit

I believe this may be the same related issue... https://ask.openstack.org/en/question/100543/instance-cant-boot-without-throwing-any-errors/ (https://ask.openstack.org/en/question...)

BigQEd gravatar imageBigQEd ( 2017-01-03 08:17:44 -0500 )edit

Hi

The same error.

Environment - CentOS 7.2 - OpenStack Newton

I install and config /etc/nova/nova.conf ..... virt_type=kvm

and check VT support, it is ok

Pic: http://prntscr.com/e4ei7h

To Thanh Cong gravatar imageTo Thanh Cong ( 2017-02-04 08:20:36 -0500 )edit

Any updates on this issue?

BigQEd gravatar imageBigQEd ( 2017-02-13 15:07:23 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2017-08-30 14:13:12 -0500

trakatelis gravatar image

If your host is centos/rhel 7.3 running as a VM on ESXi, there is a quick fix to have hardware assisted virtualization (virt_type = kvm) work.

In the [libvirt] section of /etc/nova/nova.conf set hw_machine_type as follows:

hw_machine_type = x86_64=pc-i440fx-rhel7.2.0

edit flag offensive delete link more

Comments

This works like a charm!!!! Thanks trakatelis!!

zxslm gravatar imagezxslm ( 2019-06-21 21:21:08 -0500 )edit
1

answered 2017-05-01 11:38:15 -0500

BigQEd gravatar image

updated 2017-05-01 11:40:18 -0500

A "work around" is to use virt_type=qemu and cpu_mode=none in nova.conf, however, if virt_type kvm is needed I'm not sure the current qemu-kvm version has a solution. There seems to be a resolution when libvirtd moves to 2.5.0 but that is not released yet.

See the following bugs:

https://bugzilla.redhat.com/show_bug.cgi?id=1404627 (https://bugzilla.redhat.com/show_bug....) https://bugs.launchpad.net/nova/+bug/1653430 (https://bugs.launchpad.net/nova/+bug/...)

edit flag offensive delete link more

Comments

Thank you, I tried and succeeded. I install OPS in Centos 7.1

vanduc95 gravatar imagevanduc95 ( 2017-08-11 11:16:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

4 followers

Stats

Asked: 2016-12-23 07:45:44 -0500

Seen: 6,787 times

Last updated: Aug 30 '17