Swift proxy server not starting up

asked 2016-12-23 05:05:55 -0500

os-noob gravatar image

updated 2017-01-16 15:09:03 -0500

rbowen gravatar image


I am trying to install swift proxy server using the guide given in http://docs.openstack.org/liberty/ins....

After following all the steps and installing all the packages, i was trying to start the proxy server in the controller node using the command swift-init proxy-server start. I get the below error:

controller@controller01:~$ sudo swift-init proxy-server start
Starting proxy-server...(/etc/swift/proxy-server.conf)
Traceback (most recent call last):
  File "/usr/bin/swift-proxy-server", line 23, in <module>
    sys.exit(run_wsgi(conf_file, 'proxy-server', **options))
  File "/usr/lib/python2.7/dist-packages/swift/common/wsgi.py", line 862, in run_wsgi
    _initrp(conf_path, app_section, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/swift/common/wsgi.py", line 982, in _initrp
  File "/usr/lib/python2.7/dist-packages/swift/common/utils.py", line 1506, in get_logger
    raise e
socket.error: [Errno 111] Connection refused

I could not find any swift logs in /var/logs directory. So no idea how to debug it. My swift-proxy-server configuration is here -> https://paste.ubuntu.com/23672651/

Any help is appreciated.

edit retag flag offensive close merge delete


Hi, it sounds that whatever implements syslog (syslogd/rsyslogd/syslog-ng...) is misconfigured/not functioning in your system. Use things like 'logger'/netstat/ps/check configuration files to check that part

volenbovsky gravatar imagevolenbovsky ( 2016-12-23 07:39:34 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2017-03-10 10:52:54 -0500

This link might helps you. It has many solutions and caveats. http://tipsonopenstackswift.blogspot.com/ (http://tipsonopenstackswift.blogspot....)

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2016-12-23 05:05:55 -0500

Seen: 200 times

Last updated: Jan 16 '17