Ask Your Question
0

OVS Issue ! - Challenge

asked 2016-12-14 09:10:31 -0500

Sofiane68 gravatar image

I installed OpenStack in 3 nodes from apt packages :


1 controller

  • 1 interface for mgmt network

1 compute

  • 1 interface for mgmt network

  • 1 interface for vlan network (no ip addr)


1 network

  • 1 interface for mgmt network

  • 1 interface for vlan network (no ip addr)

  • 1 interface for external network

    STEP TO REPRODUCE

on both compute/network node

  • create one br-int ovs bridge
  • create one br-eth1 ovs bridge and attach it to eth1

PROBLEM

training@controller01:~$ neutron agent-list
+--------------------------------------+--------------------+-------------------------------+-------------------+-------+----------------+---------------------------+
| id                                   | agent_type         | host                          | availability_zone | alive | admin_state_up | binary                    |
+--------------------------------------+--------------------+-------------------------------+-------------------+-------+----------------+---------------------------+
| 53dba58e-9611-4bdb-a4f0-7ccc213c8250 | DHCP agent         | network01.learningneutron.com | nova              | :-)   | True           | neutron-dhcp-agent        |
| 9a45e90d-fb26-4f0e-a58a-0bf7aa422881 | L3 agent           | network01.learningneutron.com | nova              | :-)   | True           | neutron-l3-agent          |
| a6ab34e0-9c01-4c9b-82f5-4fc19d729dad | Metadata agent     | network01.learningneutron.com |                   | :-)   | True           | neutron-metadata-agent    |
| b47f6fbf-499a-4e32-a460-30cc86fe7640 | Open vSwitch agent | compute01.learningneutron.com |                   | :-)   | True           | neutron-openvswitch-agent |
+--------------------------------------+--------------------+-------------------------------+-------------------+-------+----------------+---------------------------+

BUT

root@network01:/etc/neutron/plugins/ml2# tail -f /var/log/neutron/openvswitch-agent.log
2016-12-14 16:03:48.239 31511 ERROR neutron.plugins.ml2.drivers.openvswitch.agent.ovs_neutron_agent [-] Exit code: 1; Stdin: ; Stdout: ; Stderr: sudo: no tty present and no askpass program specified
 Agent terminated!
2016-12-14 16:03:50.712 31554 INFO neutron.common.config [-] Logging enabled!
2016-12-14 16:03:50.713 31554 INFO neutron.common.config [-] /usr/bin/neutron-openvswitch-agent version 8.3.0
2016-12-14 16:03:50.770 31554 ERROR neutron.agent.ovsdb.impl_vsctl [-] Unable to execute ['ovs-vsctl', '--timeout=10', '--oneline', '--format=json', '--', '--may-exist', 'add-br', 'br-int', '--', 'set', 'Bridge', 'br-int', 'datapath_type=system']. Exception: Exit code: 1; Stdin: ; Stdout: ; Stderr: sudo: no tty present and no askpass program specified

CONF FILES

/etc/neutron/plugins/ml2/

root@network01:/etc/neutron/plugins/ml2# catmin openvswitch_agent.ini
[DEFAULT]
[agent]
[ovs]
bridge_mappings = physnet1:br-eth1
[securitygroup]
firewall_driver = iptables_hybrid
root@network01:/etc/neutron/plugins/ml2#

root@network01:/etc/neutron/plugins/ml2# catmin ml2_conf.ini
[ml2]
type_drivers = flat,vlan,gre,vxlan
tenant_network_types = vlan
mechanism_drivers = openvswitch,l2population
extension_drivers = port_security
[ml2_type_vlan]
network_vlan_ranges = physnet1:1000:1020
[ml2_type_gre]
[securitygroup]
enable_security_group = True
enable_ipset = True
firewall_driver = neutron.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver
[ovs]
[agent]

Any IDEA?

Cheers

edit retag flag offensive close merge delete

Comments

Looks like a sudo misconfiguration. There is a requiretty option in the sudoers file afaik; disable it and you should be fine.

Bernd Bausch gravatar imageBernd Bausch ( 2016-12-14 09:30:07 -0500 )edit

Do you mean this one ?

root@network01:~# cat /etc/sudoers.d/neutron_sudoers
Defaults:neutron !requiretty

neutron ALL = (root) NOPASSWD: /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf *
Sofiane68 gravatar imageSofiane68 ( 2016-12-14 09:48:32 -0500 )edit
1

I resolved it the problem was that I had two differents lines containing :

the first :

[agent]
root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf

[agent]
root_helper = sudo /usr/local/bin/neutron-rootwrap /etc/neutron/rootwrap.conf
Sofiane68 gravatar imageSofiane68 ( 2016-12-14 10:08:53 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2016-12-16 10:43:18 -0500

volenbovsky gravatar image

(reposting comment of 'Sofiane68' as answer - please use answer for something that answers the question asked ;)

"I resolved it the problem was that I had two differents lines containing :

the first :

[agent]
root_helper = sudo /usr/bin/neutron-rootwrap /etc/neutron/rootwrap.conf

[agent]
root_helper = sudo /usr/local/bin/neutron-rootwrap /etc/neutron/rootwrap.conf"
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-12-14 09:10:31 -0500

Seen: 220 times

Last updated: Dec 16 '16