Ask Your Question
0

LBaaS v2 error

asked 2016-12-13 07:03:35 -0500

SyCode7 gravatar image

I am trying out lbaas v2 in devstack with newton with the command $ neutron lbaas-loadbalancer-create --name lb01 97a8f831-9b7d-413a-bec8-e37bd95f4fa8I have the error below :

Driver error: HTTPConnectionPool(host='127.0.0.1', port=9876): Max retries exceeded with url: /v1/loadbalancers (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7f1464d56e50>:  Failed to establish a new connection: [Errno 111] ECONNREFUSED',)) Neutron server returns request_ids: ['req-2254174c-3b75-4914-a944-17b33ea4aba9']

I am not sure if there is something I am missing out or some troubleshooting approaches.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-01-24 15:31:03 -0500

johnsom gravatar image

This error indicates that neutron is unable to reach the octavia API server. It looks like the configuration is set for the octavia API server to be listening on 127.0.0.1 (localhost) and port 9876. Please check that octavia is up and running on that IP and port. You can do so by using "netstat -an | grep 9876"

edit flag offensive delete link more

Comments

Hi Johnson. I get no respnse after running "netstat -an | grep 9876". So I did a restack and now I do not see the former eror again. However the same command $ neutron lbaas-loadbalancer-create --name lb01 xxxx return anoter error The resource could not be found.<br /><br />!!

SyCode7 gravatar imageSyCode7 ( 2017-02-24 17:40:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2016-12-13 07:03:35 -0500

Seen: 303 times

Last updated: Jan 24 '17