Devstack deployment error

asked 2016-12-08 13:03:38 -0500

vmem_intern gravatar image

Hello everyone,

I get the following error when deploying devstack:

It has something to do with it expecting a different version of the python-keystoneclient. I tried removing it from the system and have devstack install it but it installs the wrong one. I also tried modifying the /opt/stack/keystone/requirements.txt file but it keeps using the default values. Anything on how to solve this?

2016-12-08 18:51:10.970 | Exception:
2016-12-08 18:51:10.970 | Traceback (most recent call last):
2016-12-08 18:51:10.970 |   File "/usr/local/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main
2016-12-08 18:51:10.970 |     status = self.run(options, args)
2016-12-08 18:51:10.970 |   File "/usr/local/lib/python2.7/dist-packages/pip/commands/install.py", line 335, in run
2016-12-08 18:51:10.970 |     wb.build(autobuilding=True)
2016-12-08 18:51:10.970 |   File "/usr/local/lib/python2.7/dist-packages/pip/wheel.py", line 749, in build
2016-12-08 18:51:10.970 |     self.requirement_set.prepare_files(self.finder)
2016-12-08 18:51:10.970 |   File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 380, in prepare_files
2016-12-08 18:51:10.970 |     ignore_dependencies=self.ignore_dependencies))
2016-12-08 18:51:10.970 |   File "/usr/local/lib/python2.7/dist-packages/pip/req/req_set.py", line 521, in _prepare_file
2016-12-08 18:51:10.970 |     req_to_install.check_if_exists()
2016-12-08 18:51:10.970 |   File "/usr/local/lib/python2.7/dist-packages/pip/req/req_install.py", line 1036, in check_if_exists
2016-12-08 18:51:10.970 |     self.req.name
2016-12-08 18:51:10.970 |   File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 558, in get_distribution
2016-12-08 18:51:10.970 |     dist = get_provider(dist)
2016-12-08 18:51:10.970 |   File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 432, in get_provider
2016-12-08 18:51:10.970 |     return working_set.find(moduleOrReq) or require(str(moduleOrReq))[0]
2016-12-08 18:51:10.970 |   File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 968, in require
2016-12-08 18:51:10.970 |     needed = self.resolve(parse_requirements(requirements))
2016-12-08 18:51:10.970 |   File "/usr/local/lib/python2.7/dist-packages/pip/_vendor/pkg_resources/__init__.py", line 859, in resolve
2016-12-08 18:51:10.970 |     raise VersionConflict(dist, req).with_context(dependent_req)
2016-12-08 18:51:10.970 | ContextualVersionConflict: (python-keystoneclient 3.8.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('python-keystoneclient!=1.8.0,<3.0.0,>=1.6.0'), set(['glance']))
2016-12-08 18:51:11.105 | +inc/python:pip_install:1                  exit_trap
2016-12-08 18:51:11.112 | +./stack.sh:exit_trap:487                  local r=2
2016-12-08 18:51:11.121 | ++./stack.sh:exit_trap:488                  jobs -p
2016-12-08 18:51:11.129 | +./stack.sh:exit_trap:488                  jobs=
2016-12-08 18:51:11.136 | +./stack.sh:exit_trap:491                  [[ -n '' ]]
2016-12-08 18:51:11.144 | +./stack.sh:exit_trap:497                  kill_spinner
2016-12-08 18:51:11.152 | +./stack.sh:kill_spinner:383               '[' '!' -z '' ']'
2016-12-08 18:51:11.160 | +./stack.sh:exit_trap:499                  [[ 2 -ne 0 ]]
2016-12-08 18:51:11.167 | +./stack ...
(more)
edit retag flag offensive close merge delete

Comments

I get the Same error Did u find a solution ??

Abdullah Shafiq gravatar imageAbdullah Shafiq ( 2016-12-30 09:32:34 -0500 )edit

I have the same error !! Can anyone solve this ?

SyCode7 gravatar imageSyCode7 ( 2017-01-17 05:23:26 -0500 )edit

I also having the similar issue on ubuntu 16.04, but is with the keystoneauth1 version. I removed the v2.4 in dist-pack then used pip to install ==2.16. Checked the version and it showed 2.16. However, devstack reinstalled the 2.4 version and show up in the dist-package.plese help!

dadawa gravatar imagedadawa ( 2017-01-25 09:38:30 -0500 )edit